2

I have a directory in Desktop named Project. I tried opening it using the cd command but it is not opening. What's the reason?

Check the screenshot. The directory has all the required permissions.

I tried with the root user also, but facing the same problem.

Screenshot

1
  • 1
    Can you do your screenshot with Alt+PrintScreen. It's not visible this way, forcing me to open it in a new Window. Nice background BTW.
    – tshepang
    Commented Jul 17, 2011 at 18:14

5 Answers 5

28

It looks to me like the Project directory has a space at the start of it, so try:

cd " Project"

If it's something other than a space (say a tab) then

cd *Project

should do the trick.

13

There is a white space before Project.

Try this:

cd \ Project

or

cd ' Project'

or

cd " Project"
8

There seems to be an extra space, try:

$ cd " Project"
7

Looks like the directory starts with a space. Try cd \ Project

0

Am I the only one who thinks the OP's screen snapshot is a bit strange?

"ls -ll" should sort by filename. If the "Project" file began with some invisible character than looks like a space, why does it sort between "perl" and "Screenshot.png"?

If I go into any directory and do "mkdir ' Project'", then "ls -ll" sorts it at the top of the list.

This looks like a listing produced by "ls -lt".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .