1

I have a research on author attribution compression distance. And I should use "Complearn" ,which is a compression program, in my work. But in the beginning I have problem in installing this program.

1) I download program from this link into Linux Mint (which is in virtual machine in my Windows computer (VM in VirtualBox));

http://www.complearn.org/downloads/libcomplearn-1.1.7.tar.gz

2) I wrote in program’s terminal window one by one (in program directory of course),

./configure

( After configure step I got some errors about requirement dependencies , for ex. gsl,zlib. etc. I installed all of them. At last glib required.And I installed it to but it gave me one more error its about old version glib exists.Error was this:

    checking for GLIB - version >= 2.0.0... 
*** 'pkg-config --modversion glib-2.0' returned 2.42.0, but GLIB (2.40.2)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error: must have glib >= 2.0.0 and gobject installed

I solved it with this command :

echo $LD_LIBRARY_PATH export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib

After that I try ./configure step, it didn't fail.)

then

 make

And its failed with this error :

> In file included from anydecompress.c:32:0:
> /usr/local/include/glib-2.0/glib/garray.h:29:2: error: #error "Only <glib.h> can be included directly."
>   #error "Only <glib.h> can be included directly."
>   ^
> In file included from /usr/local/include/glib-2.0/glib/garray.h:32:0,
>                  from anydecompress.c:32:
> /usr/local/include/glib-2.0/glib/gtypes.h:29:2: error: #error "Only <glib.h> can be included directly."
>  #error "Only <glib.h> can be included directly."
>  ^
> In file included from /usr/local/lib/glib-2.0/include/glibconfig.h:9:0,
>                  from /usr/local/include/glib-2.0/glib/gtypes.h:32,
>                  from /usr/local/include/glib-2.0/glib/garray.h:32,
>                  from anydecompress.c:32:
> /usr/local/include/glib-2.0/glib/gmacros.h:33:2: error: #error "Only <glib.h> can be included directly."
>   #error "Only <glib.h> can be included directly."
>  ^ 
> In file included from /usr/local/include/glib-2.0/glib/gtypes.h:34:0,
>                  from /usr/local/include/glib-2.0/glib/garray.h:32,
>                  from anydecompress.c:32:
> /usr/local/include/glib-2.0/glib/gversionmacros.h:29:2: error: #error "Only <glib.h> can be included directly."
>  #error "Only <glib.h> can be included directly." 
>  ^ 
> anydecompress.c: In function ‘main’:
> anydecompress.c:59:3: warning: ‘g_type_init’ is deprecated (declared at /usr/local/include/glib-2.0/gobject/gtype.h:679) [-Wdeprecated-declarations]    
>  g_type_init ();   
> ^
> make[2]: *** [anydecompress-anydecompress.o] Error 1
> make[2]: Leaving directory `/home/kubra/libcomplearn-1.1.7/src' 
> make[1]: *** [all] Error 2
> make[1]: Leaving directory `/home/kubra/libcomplearn-1.1.7/src' 
> make: *** [all-recursive] Error 1

What does it mean? What should I do to solve this problem? Could you please help me? I didn't find any suggestions to fix this error in my googling.

Thanks.

  • How did you install libglib2.0-dev? it appears to be in /usr/local so I assume it is not the standard repository version: what version is it (pkg-config --modversion glib-2.0) and are you sure it's compatible? – steeldriver Nov 16 '14 at 18:26
  • Its in /usr/local/lib , because of it gives me error in ./configure step (error about old version glib 2.0 exists) , I moved files with these commands: ** echo $LD_LIBRARY_PATH export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib** And Modversion is : ** pkg-config --modversion glib-2.0 2.42.0** – user2304054 Nov 16 '14 at 21:28
  • Please edit your post to include that information - including the complete ./configure error message that occurred before, if you can remember it. In general, manually moving files and using LD_LIBRARY_PATH should be an absolute last resort - my advice would be to use repository versions if at all possible. FWIW I downloaded the archive and was able to build it on Ubuntu 12.04 with libglib2.0-dev version 2.32.4 – steeldriver Nov 16 '14 at 21:42
  • @steeldriver I edited post please check. And I tried one more './configure' step it gave me this error again and I used 'LD_LIBRARY_PATH' command , it solved again. But still have in trouble in make step. You may right, something wrong about moving files. Any suggestions , what do you mean "use repository versions"? I downloaded all the required programs as archive then try to install with terminal window. (With these steps : './configure' 'make' and 'make install' ) It works for the others. – user2304054 Nov 17 '14 at 7:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.