5

I have a problem adjusting my laptop's brightness. This is a hardware problem but I can solve it with ccsm, but other programs do not work for me, e.g., xgamma, etc.

Now I am running Fedora 15 and Gnome3 I cannot use compiz: is there another solution?

  • I think this problem is about Gnome 3, not Fedora – fronthem Jul 17 '11 at 5:44
2

Try editing /etc/default/grub to set GRUB_CMDLINE_LINUX to acpi_osi=Linux and then running update-grub. I found it in this Ubuntu Forums post; it worked on my Acer Aspire, but I'm not sure if it works on other computers

  • how can i config grub in fedora dont hav /etc/default/grub – fronthem Jul 18 '11 at 19:41
  • This solution worked on my HP Envy 17 2001g while running Crunchbang Statler with Kernel 3.2... just saying, if anyone comes across here :D – Marco May 28 '12 at 0:45
2

I was with the same problem in my laptop, a Dell Vostro 3300 with Ubuntu 11.04, this configuration solved my problem.

  • Edit /etc/Xorg/xorg.conf to add the following line under Section "Device":

    Option "RegistryDwords" "EnableBrightnessControl=1"
    
  • Edit /etc/default/grub and addacpi_osi=Linuxto theGRUB_CMDLINE_LINUX` setting, i.e.

    GRUB_CMDLINE_LINUX="acpi_osi=Linux"
    

    then run sudo update-grub and reboot.

  • Please do more than just link to an answer. At the very least summarize the answer or copy the most important parts of the config you reference into your answer. – Caleb Jul 18 '11 at 13:30
  • edit /etc/default/grub to change the line into: GRUB_CMDLINE_LINUX="acpi_osi=Linux" /etc/default/grub in fedora not found. How can i config grub? – fronthem Jul 19 '11 at 11:46
2

OK, I found a way to solve this problem on Acer with Fedora 15 (thanks to Fedora forums and answers here):

  1. Update the BIOS to the lastest version.
  2. Edit /etc/Xorg/xorg.conf to add the following line under Section "Device":

    Option "RegistryDwords" "EnableBrightnessControl=1"
    
  3. Edit /boot/grub/grub.conf to add the parameters acpi_backlight=vendor acpi_osi=Linux on the kernel command line (at the end of the line that looks like linux /vmlinuz root=/dev/sda1 ro).

  4. Reboot.
1

I only had to add

Option "RegistryDwords" "EnableBrightnessControl=1"

to /etc/Xorg/xorg.conf. When adding the parameters (which are mentioned in other posts) to /etc/default/grub, the brightness adjustment did still work but displaying the brightness level when changing the brightness did not change any more.

Im running Ubuntu 11.10 and Gnome3, on a Lenovo T420s

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.