Linux Mint 17 Cinnamon (Ubuntu 14.04)

HDA Intel PCH

The microphone works well (tested with VLC's capture mode), but Skype won't catch any sound. Only PulseAudio is listed in Skype's configuration as microphone option. Amplifying the input audio to the very top (>100%) manages to get some sound, but it's distorted and still almost inaudible.

Solutions tested without success:

  • Trying to configure it trough ALSA instead of PulseAudio (many sources, this one for example). No luck tweaking the few options available.
  • Installing gstreamer-properties to set a different default input (source). No difference.
  • Uninstalling/disabling PulseAudio (many sources). No good done. This is actually a bad idea.
  • Adding the options snd-hda-intel model= bit to /etc/modprobe.d/alsa-base.conf (source). This is also a bad idea.
  • Using gnome-alsamixer (source). Couldn't even launch it.
  • Adding the package libasound2-plugins:i386 (source). No effect.
up vote 3 down vote accepted

SkypeTroubleshooting article in Ubuntu's Help Wiki solved the issue very neatly. I used the "older Ubuntu versions" instructions.

Skype has been known to mess up the mixer settings. So disable the automatic configuration of the mixer controls in Skype: right-click with your mouse on the Skype icon in the system tray - Options - Sound Devices - remove the tick at: Allow Skype to automatically adjust my mixer levels. Click Apply. Then close Skype (right-click with your mouse on the Skype icon - Quit).

Then use Synaptic Package Manager to install pavucontrol (Pulse Audio Volume Controller). Use that application to set up your input device. Most built-in mics are mono. The default setting on the Input Control is to lock the R&L channel together. By reading the mono mic as stereo, PulseAudio cancels the input. Click on the middle button on the upper right of the control panel to unlock the R&L channel. Move either the left or right channel to 10 leaving the other channel about 90. You should now see the VU meter sensing sound. Now start Skype again. The test call should register your voice now.

protected by Community Jan 28 '15 at 13:48

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.