2

After I've installed proprietary FGLRX driver (version 1:14.9+ga14.201-2) from Debian 8 Jessie repositories, my cursor became invisible. All mouse actions are working correctly, just can't see the cursor.

I've got Lenovo E420 laptop with Intel/AMD hybrid graphics, discrete card is Radeon HD6630M.

After install, I've created /etc/X11/xorg.conf file with aticonfig --initial . FGLRX driver seems working correctly. I can even see cursor in OpenGL apps like games. But after return to desktop it's gone.

I'm using KDE, but this issue seems not to be dependent on environment - tried eg. JWM.

When I delete xorg.conf, I can see cursor again, but driver is not working.

Kernel version is 3.16.0-4-amd64.

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M]

$ cat /etc/X11/xorg.conf
Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
  • I guess I have the same problem. I have a mouse pointer on my second monitor though. – RobAu Sep 8 '15 at 7:40
  • Turning off my laptop display moves the 'invisible mouse' to my second monitor. – RobAu Sep 8 '15 at 7:43
  • This seems to be different problem from mine, but you could try new driver from Stretch or Sid repo (15.7). – Ludo Sep 9 '15 at 10:36
0

Installing fglrx-driver (1:15.7-3) from Debian 9 Stretch repository solves the problem.

protected by Community Apr 30 '15 at 20:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.