2

I just bought a new Dell Inspiron 7347 for my mother. It is supported officially by Ubuntu 12.04 LTS so I guessed that Linux would go nicely on it. Well.

I installed Mint 17 KDE (based on Ubuntu 14.04 LTS), which comes with kernel 3.13.0. The wireless was not active, I had to install one of the broadcom drivers in the messy Ubuntu repo: sudo apt-get install bcmwl-kernel-source. The package provides the wl module which is automatically loaded: all fine. However, the touchpad also refuses to work (touchscreen works fine). I tried several kernels: all kernels >= 3.15.0 have working touchpad but non-working wireless: the wl module is missing. Kernels < 3.15.0 have working wifi but non-working touchpad. For now, I'm trying to keep on kernel 3.13 and fix the touchpad.

xf86-input-mtouch is installed.

I managed to track down what seems wrong with the touchpad, which by the way is correctly recognized by xinput:

xinput
    ⎡ Virtual core pointer                          id=2    [master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
    ⎜   ↳ Logitech USB-PS/2 Optical Mouse           id=10   [slave  pointer  (2)]
    ⎜   ↳ ELAN Touchscreen Pen                      id=12   [slave  pointer  (2)]
    ⎜   ↳ ELAN Touchscreen                          id=13   [slave  pointer  (2)]
    ⎜   ↳ DLL0674:00 06CB:75DB                      id=14   [slave  pointer  (2)]
    ⎜   ↳ SynPS/2 Synaptics TouchPad                id=16   [slave  pointer  (2)]
    ⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Integrated_Webcam_HD                      id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=15   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=17   [slave  keyboard (3)]

What's wrong is that there are too many touchpads recognized.

    ls /dev/input
by-id    event0  event10  event12  event14  event16  event3  event5  event7  event9  mouse0  mouse2  mouse4
by-path  event1  event11  event13  event15  event2   event4  event6  event8  mice    mouse1  mouse3

More specifically:

    ls -l /dev/input/by-path
pci-0000:00:14.0-usb-0:2:1.0-event-mouse -> ../event5
pci-0000:00:14.0-usb-0:2:1.0-mouse -> ../mouse0
pci-0000:00:14.0-usb-0:5:1.0-event -> ../event16
pci-0000:00:14.0-usb-0:7:1.0-event -> ../event14
pci-0000:00:14.0-usb-0:7:1.0-event-mouse -> ../event13
pci-0000:00:14.0-usb-0:7:1.0-mouse -> ../mouse2
platform-i8042-serio-0-event-kbd -> ../event4
platform-i8042-serio-1-event-mouse -> ../event6
platform-i8042-serio-1-mouse -> ../mouse1
platform-INT33C3:00-event-mouse -> ../event15
platform-INT33C3:00-mouse -> ../mouse4

    ls -l /dev/input/by-id/
usb-CN0GNXH57248749CA1ELA00_Integrated_Webcam_HD-event-if00 -> ../event16
usb-ELAN_Touchscreen-event-if00 -> ../event14
usb-ELAN_Touchscreen-event-mouse -> ../event13
usb-ELAN_Touchscreen-mouse -> ../mouse2
usb-Logitech_USB-PS_2_Optical_Mouse-event-mouse -> ../event5
usb-Logitech_USB-PS_2_Optical_Mouse-mouse -> ../mouse0

Also, at login KDE warns me of having found too many touchpads and that this is unsupported. Using newer kernels, this still happens but touchpad works (as stated, wireless does not).

Looking at the Archwiki, I tried setting up something like:

cat /etc/X11/xorg.conf.d/50-synaptics.conf
Section "InputClass"
    Identifier "touchpad catchall"
    Driver "synaptics"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event6"
        Option "TapButton1" "1"
        Option "TapButton2" "2"
        Option "TapButton3" "3"
EndSection

where event6 was gotten from:

cat /proc/bus/input/devices
...
I: Bus=0011 Vendor=0002 Product=0007 Version=01b1
N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input6
U: Uniq=
H: Handlers=mouse1 event6 
B: PROP=5
B: EV=b
B: KEY=e520 610000 0 0 0 0
B: ABS=660800011000003
...

However, this does not seem to work. But I guess that a xorg rule is the right path forward.

I also attach the outputs of:

(with 3.13.0 kernel)
lsmod: pastebin.com/U16B0nTr
lsusb: pastebin.com/kAJw2H4J
lspci: pastebin.com/JvXLHHZH
cat /var/log/Xorg.0.log: /pastebin.com/mZ65RQEV

(with 3.17.3 kernel)
lsmod: pastebin.com/RaFmnj0f
lsusb: pastebin.com/jjbxng5N
lspci: pastebin.com/sDrgW5M5
cat /var/log/Xorg.0.log: pastebin.com/MYWEe1PK

  • All apologies. I just did a quick google and there's a review claiming it was an Intel 7265. – goldilocks Nov 15 '14 at 17:12
  • No problem at all goldilocks. – AF7 Nov 15 '14 at 17:17
0

I decided to try to walk around the problem by using a newer kernel and getting wifi to work on that. I tried several kernel-wifi module combo, and in the end 3.16.0 and latest bmcwl-kernel-source worked sweetly. The touchpad behaved strangely but some xorg.org.d wules fixed that pronto.

So the question above still stands, but the workaround is actually better.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.