1

For some time back I installed Linux mint 17 on my desktop machine, which is a dell studio 540. During the installation process, I did not have any internet connection, because my wireless card needed a proprietary driver to work (fixed using fwcutter). So recently I wanted to install a newer distro kernel due to some bug fixes, using the software manager. It installs fine, but when rebooting the grub won't run the new kernel. So I thought I should check out the grub versions:

Grub version output from terminal: grub --version grub (GNU GRUB 0.97)

Grub version from the grub menu when booting into grub: GNU GRUB version 2.02-beta2-9

Why are they not the same ? Could it be a missing update, due to the lost internet connection during installing the Linux mint ? btw: I have no problem installing new kernels on my laptop, which did not need any proprietary driver for the wireless.

2
  • 1
    Is this a dual boot machine? Is the grub from the older installation?
    – Anthon
    Commented Nov 15, 2014 at 13:37
  • Hi Anthon, no not anymore. I had dualboot before, but when installing linux mint I decided to clear the entire hard drive. So I do not have dual boot.
    – Nicco
    Commented Nov 15, 2014 at 14:19

2 Answers 2

0

Grub, its version you get printed on the command line, is considered legacy in many distributions. It's first in your path, that's why 0.97 is printed. The grub used in boot partition of you installation is newer. I think you should uninstall the old grub and perhaps re-install the new one. When installing new kernel, it seems that its configuration is added to the legacy and not to the new grub.
Please note, there are links inside my answer, their look is dimmed somehow

9
  • Hi igorepst, thank you for the answer. well when you say uninstall the old one, does that mean I have 2 versions of grub installed ? btw, lets say i get the new kernel running, do i have to fix the proprietary driver again ? cheers Nicolai
    – Nicco
    Commented Nov 15, 2014 at 16:17
  • Yes, you have 2 different versions installed, or else you would not see 0.97 and 2.02. About the driver: unfortunately I have no idea how this driver works, but it's possible that the driver won't work at all (because, say, something related was changed inside the kernel), or it will work as is or after re-install
    – igorepst
    Commented Nov 15, 2014 at 16:42
  • Ok, so i removed the 097, easily from the terminal. The confusing part is that how to reinstall the new one, I assume you mean the 2.02. I,ve seen posts on how to do that from a live cd/usb, but in this case that's not the thing. Or is it?
    – Nicco
    Commented Nov 15, 2014 at 17:15
  • First of all you may use the first link from my answer as the reference. Arch Wiki is one of the nest wikis about Linux. Second, see this. Basically, let's start with sudo grub-mkconfig -o /boot/grub/grub.cfg
    – igorepst
    Commented Nov 15, 2014 at 19:33
  • I appreciate your help igorepst, thank you. For now i decided to stay with the old kernel, since I don't want to screw up the wireless again.
    – Nicco
    Commented Nov 17, 2014 at 11:05
0

I know this probably won’t help the asker since it’s been 7 years, but figured I’d give an answer if somebody is looking for one. Grub 0.97 is a legacy build for MBR/BIOS. Grub 2, however, is built for EFI. What’s likely happening is that Linux is recognizing 0.97 as the current version of Grub used, but the computer is using the EFI build. See if you can disable UEFI booting or set Legacy only in your BIOS and then check the Grub version again, that should answer your question.

1
  • GRUB2 has implementations for multiple architectures, each with an architecture ID: x86_64-efi is the usual UEFI version, while i386-pc is the version of GRUB2 for BIOS. The OP might have had both GRUB Legacy and the newer GRUB 2 installed, and should perhaps have done something to update-grub (the standard command of Debian and relatives to update the bootloader, invoked by the package manager as needed) to make it update the configuration of GRUB 2 instead of the GRUB Legacy.
    – telcoM
    Commented May 24, 2023 at 18:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .