2

I am hoping to use dnsmasq to provide for a wireless AP on Debian Wheezy.

Issue: daemon.log is filling up with repeated 'DHCPREQUEST' and 'DHCPACK' messages from the one test client (win7).

Config file:

interface=wlan0
dhcp-range=wlan0,192.168.70.10,192.168.70.200,12h
dhcp-option=252,"\n"

This last line was supposed to stop win7 from nagging but it doesn't seem to be working. daemon.log is getting these messages every 8-10 seconds.

It will fill up the file system in short order if this continues.

What I've tried:

ipconfig /release and /renew on the client
adding the last line to the config file
lots of searching

I've seen other references to this message trail but they are usually associated with other DHCP servers.

What step did I miss?


EDIT - /var/log/syslog is getting these messages too


EDIT - output of dhcp requests logging:

Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 available DHCP range: 192.168.70.10 -- 192.168.70.200
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 client provides name: brp-s212
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 vendor class: MSFT 5.0
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 DHCPREQUEST(wlan0) 192.168.70.11 00:##:##:##:##:##
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 tags: wlan0
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 DHCPACK(wlan0) 192.168.70.11 00:##:##:##:##:## brp-s212
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 requested options: 1:netmask, 15:domain-name, 3:router, 6:dns-server,
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 requested options: 44:netbios-ns, 46:netbios-nodetype, 47:netbios-scope,
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 requested options: 31:router-discovery, 33:static-route, 121:classless-static-route,
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 requested options: 249, 43:vendor-encap
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 next server: 192.168.70.1
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 sent size: 1 option: 53 message-type 5
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 sent size: 4 option: 54 server-identifier 192.168.70.1
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 sent size: 4 option: 51 lease-time 86400
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 sent size: 4 option: 58 T1 43200
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 sent size: 4 option: 59 T2 75600
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 sent size: 4 option: 1 netmask 255.255.255.0
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 sent size: 4 option: 28 broadcast 192.168.70.255
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 sent size: 4 option: 3 router 192.168.70.1
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 sent size: 4 option: 6 dns-server 192.168.70.1
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 sent size: 11 option: 81 FQDN 03:ff:ff:##:##:##:##:##:##:##:##
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 sent size: 1 option: 31 router-discovery 00
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 sent size: 0 option: 47 netbios-scope
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 sent size: 1 option: 46 netbios-nodetype 08
Nov 17 09:24:28 odroid-01 dnsmasq-dhcp[3364]: 855385675 sent size: 4 option: 44 netbios-ns 192.168.70.1

  • Is the client accepting the offered address? Try ipconfig. The client should only renew every 6 hours or so. – BillThor Nov 15 '14 at 0:11
  • Client is Windows 7 – ethrbunny Nov 15 '14 at 14:20
  • The command ipconfig will show the IP address, if any, your Windows 7 has accepted. – BillThor Nov 15 '14 at 23:12
  • Duh..yes of course.. Ipconfig shows it with a valid address. It keeps asking. For the same one over again. – ethrbunny Nov 15 '14 at 23:37
2

Option 252 should be the URL for a .pac file, something like http://example.com/wpad.dat. This might be causing your Windows 7 system from accepting the DHCP response.

If you don't have a file on a web server, try omitting that option.

You also appear to be missing some standard options. Try adding these (editted appropriately):

dhcp-option=wlan0,3,192.168.70.1                # Router
dhcp-option=6,192.168.70.1,8.8.4.4              # DNS servers
dhcp-option=wlan0,15,wlan.example.com           # Domain

These are some additional options I set.

dhcp-option=19,0                                # Option ip-forwarding off
dhcp-option=20,0                                # Source routing off
dhcp-option=27,1                                # All sub-nets are local
dhcp-option=31,0                                # Router Discovery off
dhcp-option=42,192.168.70.1                     # NTP time servers
dhcp-option=44,192.168.70.1                     # WINS server
dhcp-option=46,8                                # Netbios node type   
dhcp-option=47                                  # Empty netbios scope.
dhcp-option=119,example.com,com                 # Search List
dhcp-option=252,http://www.example.com/wpad.dat # Autocofig
  • Have tried it both with and without the 252 line. Same result. – ethrbunny Nov 15 '14 at 23:38
  • @ethrbunny I've edited to add some additional options that you may need to set. – BillThor Nov 16 '14 at 14:54
  • Hmm.. I added these and continue to get a DHCPREQUEST/DHCPACK message on the DHCP server every 10-15 seconds. – ethrbunny Nov 17 '14 at 13:26
  • @etherbunny At this point I would break out tcpdump or dhcpdump and check the contents of the traffic. These messages should only be generated in response to requests. – BillThor Nov 17 '14 at 13:42
  • Interesting: I found a reference in another forum to a similar issue(TL;DR). It suggested putting the wlan address and hostname into /etc/hosts. I did this and now I get DHCPINFORM/DHCPACK about once a minute instead of the msgs I got before. – ethrbunny Nov 17 '14 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.