3

I've been working on Solarized theme in Terminator (http://gnometerminator.blogspot.fr/p/introduction.html) for about a year on Gnome and have been very satisfied. Yesterday I switched to KDE and the results aren't as pleasing. It seems Terminator uses some of the colors from default KDE settings, instead of it's own preferences (Preferences --> Profiles --> Colors). For example when I use ls -l it displays all the directories in dark blue, identical to which KDE's main terminal Konsole displays (I think it's the one defined in /etc/DIR_COLORS). It should use the lighter blue shade defined in the profile preferences.

Does anyone know how to force Terminator to override those KDE settings?

  • What terminator? Do you mean this or this? Is this only about ls colors? – terdon Nov 14 '14 at 10:19
  • The second one (by Chris Jones). Other than ls I saw the same dark blue color in a terminal-run emacs, where it should display (and display in a a window-mode) light blue. – Robert Kusznier Nov 14 '14 at 10:25
  • Well, the ls should be easy enough to fix with my answer, the emacs colors can be set in ~/.emacs. – terdon Nov 14 '14 at 10:33
  • Most of cases it displays right colors, but there are few places in which it displays this dark blue that is impossible to read on a dark background. – Robert Kusznier Nov 14 '14 at 11:01
  • I don't use Solarized myself, but I did install some Solarized for KDE stuff a month or so ago to check it out. I'm pretty sure I got it from here. – PM 2Ring Nov 14 '14 at 13:39
2

If the only issue are the colors in the output of ls, it's easy to fix. Just set your own LS_COLORS variable and that will override anything else. So, to start, run

dircolors -p > ~/.mycolors

That will print the default values into a new file called .mycolors in your $HOME directory. Note that this will set the default colors from your current environment. You might need to edit this file and change the colors. For example, to make directories appear light blue, find the line starting with DIR in .mycolors and set it to:

 DIR 01;34

A few available colors are (from TLDP):

Black       0;30     Dark Gray     1;30
Blue        0;34     Light Blue    1;34
Green       0;32     Light Green   1;32
Cyan        0;36     Light Cyan    1;36
Red         0;31     Light Red     1;31
Purple      0;35     Light Purple  1;35
Brown       0;33     Yellow        1;33
Light Gray  0;37     White         1;37

Then, tell your shell to load that file. Assuming you're using bash, add this line to your ~/.bashrc:

dircolors -b ~/.mycolors > /dev/null

Now, all new terminal windows (shells) you open will have the right colors.

  • I'd like to set the colors with RGB precision, as Terminator lets me to do (setting the exact color hash in the configuration, e.g. #f082a8). Am I wrong that this solution doesn't let me to do this? I have all the colors already set in Terminator configuration. The only thing I need is to tell Terminator to always use those colors, instead of the system defined ones. – Robert Kusznier Nov 14 '14 at 10:59
  • @Robert I think what's happening is that some colors are not actually set in terminator and that's why it's taking the KDE defaults. At least in my terminator (0.97), I can just choose a "palette", I can't specify where these colors should be applied. I assume you're using a custom palette yourself and not the system theme right? – terdon Nov 14 '14 at 11:12
  • Right, I'm using a "Solarized" palette. I've also tried with the custom one for the same result. Does this palette not specify all the colors that the terminal can use? – Robert Kusznier Nov 14 '14 at 11:40
  • @Robert I'm not sure about the details but no, it almost certainly doesn't. There are only 16 colors in the palette while most terminals today can deal with 256. My default dircolors output shows that I can set 114 separate colors for different extensions and permissions and file types. – terdon Nov 14 '14 at 11:44
  • I did manage to finally set it. You're right. I actually needed only to change the color declaration for directories, so that it'd be taken from the palette. That didn't solve Emacs though. There are some issues with colors selected being unavailable under terminal and I didn't manage to solve them. For now I've just cancelled the Emacs theme in terminal mode, letting the terminal color things by itself. – Robert Kusznier Nov 14 '14 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.