4

According to this port, i made these configuration in my .Xresources for urxvt:

URxvt*keysym.Control-1:                \033[27;5;49~
URxvt*keysym.Control-2:                \033[27;5;50~
URxvt*keysym.Control-3:                \033[27;5;51~
URxvt*keysym.Control-4:                \033[27;5;52~
URxvt*keysym.Control-5:                \033[27;5;53~
URxvt*keysym.Control-6:                \033[27;5;54~
URxvt*keysym.Control-7:                \033[27;5;55~
URxvt*keysym.Control-8:                \033[27;5;56~
URxvt*keysym.Control-9:                \033[27;5;57~
URxvt*keysym.Control-0:                \033[27;5;48~

In my 'cat -v', when i press Control-1,

\033[27;5;49~

is printed as expected, so do other key combinations, except Control-5. When i type Control-5, nothing printed. I really don't know what is the difference for Control-5, either how to debug this problem. Is that urxvt makes some default mapping for Control-5, at least i don't make that myself. This is my full .Xresources:

URxvt*termName:                       screen-256color
URxvt*scrollBar:                      false
URxvt*scrollBar_right:                false
URxvt*urgentOnBell:                   false
URxvt*visualBell:                     false
URxvt*background:                     #2E3436
URxvt*foreground:                     #BDC3C7
URxvt*color0:                         #2E3436
URxvt*color1:                         #C0392B
URxvt*color2:                         #27AE60 
URxvt*color3:                         #F39C12
URxvt*color4:                         #3465A4
URxvt*color5:                         #75507B
URxvt*color6:                         #16A085
URxvt*color7:                         #BDC3C7
URxvt*color8:                         #555753
URxvt*color9:                         #EA6153
URxvt*color10:                        #2ECC71
URxvt*color11:                        #F1C40F
URxvt*color12:                        #729FCF
URxvt*color13:                        #AD7FA8
URxvt*color14:                        #1ABC9C
URxvt*color15:                        #FBFCFC
URxvt*colorBD:                        #BDC3C7
URxvt*font:                           xft:DejaVu Sans Mono:size=12:style=Regular:antialias=false
URxvt*boldFont:                       xft:DejaVu Sans Mono:size=12:style=Bold:antialias=false
URxvt*italicFont:                     xft:DejaVu Sans Mono:size=12:style=Italic:antialias=false
URxvt*boldItalicFont:                 xft:DejaVu Sans Mono:size=12:style=Bold Italic:antialias=false
URxvt*depth:                          32
URxvt*perl-ext-common:                default,clipboard
URxvt*iso14755:                       false
URxvt*iso14755_52:                    false

EDIT: To be clear, i am using awesome titling window manager.

1 Answer 1

1

urxvt don't seem to be the problem here (I'm using urxvt too). Maybe awesome blocks this key sequence.

Try to open urxvt alone (without awesome). To do this open another tty (ctrl-alt-fN) and type something like xinit urxvt -- :1, and try the key sequence. If this doesn't show results, try to change to sh, for example, and test again.

I was in a similar problem, time ago.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .