2

I can connect to the Internet without a problem by using wireless networks. I have a DSL connection on defined which can connect to the Internet when LAN is connected. When I plug-in network cable, network-manager icon keeps waiting for address from LAN and connecting DSL does nothing. What should I do?

Output of ifconfig:

    eth0      Link encap:Ethernet  HWaddr 28:d2:44:ce:05:84  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:22 errors:0 dropped:2 overruns:0 frame:0
          TX packets:45 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1320 (1.2 KiB)  TX bytes:15390 (15.0 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:252 errors:0 dropped:0 overruns:0 frame:0
          TX packets:252 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:18528 (18.0 KiB)  TX bytes:18528 (18.0 KiB)

wlan0     Link encap:Ethernet  HWaddr 30:10:b3:14:07:6b  
          inet addr:192.168.1.4  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::3210:b3ff:fe14:76b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5330 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5671 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3872796 (3.6 MiB)  TX bytes:1117262 (1.0 MiB)
  • I was able to connect, via 'pppoeconf' then 'pon dsl-provider' but still GUI of network manager does not work – mahdix Nov 14 '14 at 13:54
1

It looks like your cabled connection is not obtaining an IP address from the DSL connection.

This can be either because there is no DHCP server running on the network you are connecting to or because the interface is not properly configured.

Try doing the following:

  1. Install the ifupdown-extra package, (as root): apt-get install ifupdown-extra
  2. Disable the radio interface by using the hardware on/off radio switch.
  3. Check if your LAN interface (eth0) obtains an IP address
  4. If it does not, force it to obtain an IP address using dhcp: dhclient eth0
  5. If the above does not work try to setup an IP address for your interface staticly running: ip addr add 192.168.1.15 dev eth0; ip route add default via 192.168.1.1
  6. If step 4 or 5 works, test your network connection runnig network-test (tool provided by the ifupdown-extra package)

If network-manager was not able to configure your LAN interface (i.e. step 3 failed, but the others worked) maybe your system is not properly configured to make it manage interfaces. Review the following entry in the Debian Wiki: https://wiki.debian.org/NetworkManager and make sure your /etc/network/interfaces does not have any eth0 entry which would prevent it from working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.