2

While playing around with Ubuntu Server, which does not have any kind of desktop environment installed by default, I did "apt-get install startx; startx", which showed me a console in a white box, and whenever I ran a GUI application, I could see a very simple window, with which I couldn't find a way to drag around or do whatever fancy things typically expected to do as a GUI window, but it did still work. I even succeeded running the Firefox browser! The mouse cursor was a black X with white outline. And multitasking didn't seem to be possible.

I didn't install any kind of desktop environment such as KDE, GNOME, Unity, et cetera, and I wonder what the "startx" command is running.

5

Have a look at /etc/X11/Xsession.d/50x11-common_determine-startup:

if [ -z "$STARTUP" ]; then
  if [ -x /usr/bin/x-session-manager ]; then
    STARTUP=x-session-manager
  elif [ -x /usr/bin/x-window-manager ]; then
    STARTUP=x-window-manager
  elif [ -x /usr/bin/x-terminal-emulator ]; then
    STARTUP=x-terminal-emulator
  fi
fi

So basically, this tries to find an X11 session manager (something like gnome-session), and if that fails, try to find any window manager, and if even that fails, just run a terminal emulator.

Most likely you had no session manager installed and no window manager either. The fact that you couldn't move or resize any windows is of course due to the fact that you were not running any window manager. But I guess you at least had a terminal emulator installed, probably xterm.

All of these (x-session-manager, x-window-manager, x-terminal-emulator) are set up in Debian is alternatives, so it is possible for the user to select which one is preferred using update-alternatives.

I'm not sure what you mean by "multitasking didn't seem to be possible". Do you mean switching focus between windows? If yes, then that's because that's part of the window manager's job. You could try installing a very classic old bare-bones window manager like twm if you want to get something that's just one small step up from no window manager at all.

| improve this answer | |
  • I see! It seems that my OS is running a terminal emulator. What I meant by "multitasking didn't seem to be possible" is that if I run "firefox" for example, It runs just as if typing "firefox" in Xterm of Linux GUI mode. So the terminal simply waits until the running program terminates. – xiver77 Nov 14 '14 at 0:01
  • 1
    @xiver77 Ah, I see. For that, you can just run Firefox in the background like so: firefos & and your shell prompt will return while Firefox displays in another window at the same time. – Celada Nov 14 '14 at 1:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.