5

I have a ~500gb hard drive that I intend to split 50/50 for Windows 10 and Linux Mint 17. The Windows partition is 232GB and the Linux partition is, at the moment, uncreated. When I run Mint off my pen drive and go to install it, it shows the hard drive as 500gb of 'free space'. I can't install because it will wipe my Windows install.

How can I get the partition to show in Mint?

  • I have a hunch that Windows 10 uses a Filesystem Type that the Mint installer doesn't recognize, therefore the drive is empty in regards to the installer. I would file a few bugs. 1 for the installer and another for parted. – eyoung100 Nov 13 '14 at 22:33
  • Even if the filesystem is not recognized, it should still come up as something along the lines of unknown, should it not? If it shows the whole disk as completely unallocated, then perhaps it is using an unrecognized partitioning scheme. – Joe Mar 26 '16 at 13:11
0

Always make a back up first!

I did this the other day installing Ubuntu 14.10 on a Windows 10 drive. When the installation got to the part where you choose how to install I chose "something else". At that point no operating systems were detected, however, the partition showed up as "Windows bootloader".

You can mark the partition as "do not use" and then resize the "do not use" partition to make free space for linux.

The linux partition needs to be partitioned to ext4 (default), ext3, xfs, or btrfs. You also need a couple of GB to partition for linux-swap space.

  • It shows the entire hard drive as un-allocated space. – Nanor Nov 14 '14 at 0:30
  • Have you tried checking things out with gparted before starting the installation? Either that or maybe you should try the partitioning in Windows before you start. – mchid Nov 14 '14 at 1:53
  • How would I set it up on Windows? Is there a program I should use? – Nanor Nov 14 '14 at 15:44
  • @Nanor windows.microsoft.com/en-us/windows/… and this vid is a bit newer youtube.com/watch?v=VXn2CQkURgo – mchid Nov 14 '14 at 23:24
  • @Nanor you might want to try using gparted from an Ubuntu 14.10 live iso. Windows 10 showed up on my disk during install so it's worth a shot, it linux, it gparted and it's familiar. If it's just a Mint bug, you could use the Ubuntu disk to format a couple of partitions to use for the Mint install. Choose something else from the installer menu in Mint and then install directly to your preformatted partition. – mchid Nov 14 '14 at 23:31
0

Just a thought... as I have tried this my self on a machine that did support both "legacy boot" and the new standard i simply disabled the legacy in the BIOS, and then the win10 partition showed up. It could seems like *nix could have periodic "failures" seeing partitions on the new boot format :/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.