2

Story: I had Windows on one partition, and an unallocated partition. I then installed CentOS 7 on the unallocated partition. (I selected the option for the installer to automatically create the partitions for the unallocated portions of my disk.) However, GRUB failed to create a menu option for booting into Windows, which is causing me great distress.

According to http://www.tuxradar.com/answers/113:

I should first issue the rootnoverify command. But when I do, bash says:

bash: rootnoverify: command not found...

I believe GRUB2 has been installed already because I have the file /boot/grub2/grub.cfg.

Question: 1. Why is rootnoverify not found? 2. Why didn't the CentOS installer add an entry for Windows?

  • 1
    What is the output of fdisk -l (executed as root)? – Gilles Nov 13 '14 at 23:49
  • Gilles, thank you for your attention - please see my comments after Joel Davis's answer. – boxofchalk1 Nov 14 '14 at 5:21
3

Question: 1. Why is rootnoverify not found?

rootnoverify is a command for the grub shell you get when you first boot not for bash. By the time you boot into the OS it's too late to run that command. If you're already in the OS you might try adding something like this:

title Windows OS
        rootnoverify (hd0,0)
        chainloader +1

To your grub.conf after modifying it to match whatever you partition table looks like.

  1. Why didn't the CentOS installer add an entry for Windows?

Hard to say after the fact, especially as an uninvolved third party. May have been an error/misconfiguration during the installation process.

EDIT:

Actually, I think I can see what it might have been. The automatic partitioning is for using the entire disk, not just the unallocated space. I would do an fdisk -l from bash to see if the Windows partition is even still there.

  • The fdisk -l shows the NTFS partitions are intact (sorry I don't have the exact output now because I just wiped my system). I tried reinstalling a couple more times just to see if I did something wrong with the bootloader. I could not find bootloader options in the GUI installer. The symptoms I described here are for "Development and Creative Workstation". When I tried the "minimal" option, the system could not even boot up. – boxofchalk1 Nov 14 '14 at 5:15
  • I then tried the 6.6 image (DVD1), using Rawrite32 to make a bootable USB. And everything worked fine; I was able to boot into Windows. I'm really not sure what's causing the issues with CentOS 7. But I guess I'll stick with CentOS 6 for now. – boxofchalk1 Nov 14 '14 at 5:19
  • 1
    That's interesting. It might just be a bug with the installer program then. That's the part that's supposed to set that stuff up for you. – Bratchley Nov 14 '14 at 12:36
  • Yeah, the bootloader is probably not set properly. I didn't get a chance to try your grub.conf suggestion (I don't have 7 anymore) but I'll post here if I do. Thanks for helping! – boxofchalk1 Nov 14 '14 at 22:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.