1

I have a dual boot system with two partitions for Ubuntu and Arch. In Arch, whenever I need to access the Ubuntu partition, I am asked for the password.

I added a line in fstab as follows:

UUID=xxxxxx /run/media/username/Ubuntu ext4 defaults,user,noauto    0   1

I do not want to mount it automatically but allow the user to mount it without authentication.

The user is in the users, sys, storage and power groups.

  • You should add option uid=UID if you wants for one user (UID can be found by id -u or add option gid=GID for users incorporated into it. (in my system I use plugdev : GID == 46) – Costas Nov 13 '14 at 11:39
  • Can you explain a bit better the plugdev part? – To Do Nov 13 '14 at 13:03
  • There is plugdev group in my system and my user has incorporated in it. So I use the option gid=46,users,allow_other,noauto – Costas Nov 13 '14 at 14:38
  • @Costas That would be for a filesystem that doesn't track ownership, such as VFAT. Not for ext4, there's no uid or gid option because the owner of a file is the owner indicated in the filesystem. – Gilles Nov 13 '14 at 23:21
  • That's what the user option means. What command are you running exactly to do the mounting? – Gilles Nov 13 '14 at 23:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.