5

I downloaded the 32 bit .rpm (For Fedora/openSUSE) to my CentOS machine. when installing it, I got the following error.

$ rpm -ivh google-chrome-stable_current_i386.rpm
warning: google-chrome-stable_current_i386.rpm: Header V4 DSA signature: NOKEY, key ID 7fac5991
error: Failed dependencies:
        lsb >= 3.2 is needed by google-chrome-stable-12.0.742.124-92024.i386
        libcurl.so.4 is needed by google-chrome-stable-12.0.742.124-92024.i386
        xdg-utils is needed by google-chrome-stable-12.0.742.124-92024.i386

This much is clear (I guess), that I need the package lsb version greater than or equal to 3.2, libcurl.so.4 and xdg-utils. But where will I get these from. I think installing the three above packages should resolve the installation error.

Addendum: Progress was made by installing the packages lsb and xdg-utils using the command yum install <pkg_name>. But I still have the libcurl.so.4 library file as a missing dependancy. Any ideas as to how this can be resolved.

3 Answers 3

7

You'll want to use yum, which is the Redhat command-line package manager.

In this case, lsb and xdg-utils refers to rpm packages, which you can find in the Centos repos by typing yum search <pkg_name>. If you want detailed information about a package, you can use yum info <pkg_name>. Once you find the packages that you need in the repos, you can install them with sudo yum install <pkgs>.

libcurl.so.4 isn't a package name, but rather a library file provided by some package, in this case libcurl. This can be determined by using yum whatprovides <filename>. Once you determine the package, you can install it as above.

11
  • When I use yum whatprovides libcurl, I get no matches found. But the good news is that the command to install the google chrome package now says I don't have only libcurl.so.4. Any suggestions for this?
    – Thomas
    Commented Jul 16, 2011 at 7:15
  • @Thomas If you try to run 'yum localinstall google-chrome-stable_current_i386.rpm' does yum is able to resolve the dependencies?
    – Vitor Py
    Commented Jul 16, 2011 at 16:42
  • @Thomas - I'm not sure why it didn't find it, but I tested it against a different repo. You can run sudo yum clean all and then sudo yum makecache to rebuild the local yum database and try again. It's a good idea to do this periodically, anyways. However, the package you need is called libcurl. You can search/info/install it according to above instructions. Commented Jul 17, 2011 at 0:42
  • @Vitor Braga When I run yum localinstall google-chrome-stable_current_i386.rpm, I get Error: Missing Dependency: libcurl.so.4 is needed by package google-chrome-stable-12.0.742.124-92024.i386 among other details and it doesn't resolve the library file dependency.
    – Thomas
    Commented Jul 23, 2011 at 10:12
  • @Joe Internet ... after some research it seems that the command yum whatprovides libcurl.so.4 will only work on a machine that already has the package that placed the libcurl.so.4 file in that machine. It is of no use on a machine that does not already have the file. I tried running the sudo yum clean all and then sudo yum makecache to rebuild the local yum database; but this did not help. I also attempted installing the package libcurl by using the command yum install libcurl, but it returned No package libcurl available. Any other ideas I could try?
    – Thomas
    Commented Jul 23, 2011 at 10:20
0

for first time you need install this Lib sudo yum install libXScrnSaver I hed your problem and next time I installed this lib.end OK

0

In the version available in June 2022, the following command installed the dependencies needed for the Chrome RPM:

yum -y install liberation-fonts vulkan*

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .