8

If I want to disable beep sounds from stuff like bash, I add this line to "/etc/inputrc":

set bell-style none

Sadly, this doesn't work for some other events like GDM start-up and shut down. I thought that adding this line to "/etc/modprobe.d/blacklist.conf" would help:

blacklist pcspkr

That makes me wonder and doubt where the sound actually comes from.

3
  • There's no such thing as “the” beep sound. Each program or set of programs has its own sound event system (simple beeps for older programs such as bash, sound files for newer frameworks such as Gnome or KDE). Are you trying to suppress all the ones that come out of the PC speaker, as opposed to the sound card? Or all sound events in all applications, but not explicit playing with sound and movie players (in which case you have to do it one application/framework at a time)? Commented Jul 16, 2011 at 13:54
  • 1
    I want to suppress the beep that I thought came from the PC speaker. It is way too loud and I don't even need it. The sound events are something else (and I don't even enable them).
    – tshepang
    Commented Jul 16, 2011 at 14:25
  • The beep for me as a 'drip' sound, and is made by XOrg on screen capture. The was suddenly enabled of a upgrade. I can disable it by disabling "System Sounds" but I only want it disabled in XOrg. and NOT for a command like "echo $'\cg' " whcih system sounds also disables. How to I stop it just from XOrg?
    – anthony
    Commented Dec 27, 2022 at 10:52

5 Answers 5

5

Solution for GNOME 2 (Debian 6):

I tried one more thing... System -> Preferences -> Sound. This brings up the Volume Control application:

enter image description here

From there I click on Preferences which brings up another window. I then click on Beep, and that mutes window thus:

enter image description here

I then proceed to clicking on the speaker icon on PCM column, after which I become happy.

Solution for GNOME 3 (Debian 7):

Edit /etc/gdm3/greeter.gsettings such that you have this entry:

# Disabling sound in the greeter
[org.gnome.desktop.sound]
event-sounds=false

You'll probably just have to uncomment the 2 lines. Note that I can't find a way to do something like this as normal user. I guess GNOME 3 killed some configurability.

0
3

Gnome Shell (3.22) and Debian 9 (stretch)

Just go to SoundSound Effects and turn off the Alert volume like shown below:

Gnome 3 Sound panel

1

a solution i found to disable system beeps in xorg in general (when my DE settings were all already set to no beeps but i was still getting beeps) was to run xset b off. you can add this to your init file, ie ~/.xsessionrc or ~/.profile or ~/.bashrc). you can check it worked with xset q | grep bell.

source: https://blog.sleeplessbeastie.eu/2012/12/28/debian-how-to-turn-off-the-system-bell/

0

Solution for LXDE:

vim $HOME/.config/autostart/LXinput-setup.desktop

Change

Exec=sh -c 'xset m 20/10 10 r rate 500 30 b on'

to

Exec=sh -c 'xset m 20/10 10 r rate 500 30 b off'
0

GNOME Debian 12 (Bookworm)

Settings > Sound

Change the System Sounds level.

Settings Sound

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .