1

I want to import and work with my dv's which are from a SONY DCR-PC101E camcorder, I've installed alot of Video editing software on one of my systems, namely my Fedora 20 running on an old HP with Firewire. Only two of the software, I've found until now can import from the camera, Kdenlive and Kino(dead project).

NOTE: Kdenlive has some sort of distortion in the feed, so the video on my computer is distorted while it is fine on the tape. Not good. So it works for importing/editing, just not as it should.

Now I want to try Kino, as it is well known and I need something that works, but it gives an error:

WARNING: dv1394 kernel module not loaded or failure to read/write /dev/raw1394

while this works and lets me import my videos:

dvgrab -a -format raw -rewind -t prefix-

Question:

What do I need to do to give Kino life on my Fedora 20 system and use it to import dv's from my camcorder?


I've looked around and found alot of old post's working with the same error, but all where old/dated f.exmp for Fedora 7/8/12, and that's along time ago. And there where alot of talk about new Firewire and old modules.

My system is:

Fedora 20 x86_64
HP dc7700cmt 2G Ram

The software is:

Kino 1.3.4

EDIT #1

Here is tail -f /var/log/messages on the firewire:

[root@Host folder]# tail -f /var/log/messages
Nov 12 13:40:03 Host kernel: [ 1478.408673] firewire_core 0000:01:00.0: phy config: new root=ffc1, gap_count=5
Nov 12 13:40:04 Host kernel: [ 1478.999715] firewire_core 0000:01:00.0: created device fw1: GUID 0800460102f19880, S100

When I run these:

[root@Host folder]# rmmod firewire-core
[root@Host folder]# rmmod firewire-ohci

there is this output in /var/log/messages:

Nov 12 14:26:36 Host kernel: [ 4270.630102] firewire_ohci 0000:01:00.0: removed fw-ohci device

and these:

[root@Host folder]# modprobe firewire-core
[root@Host folder]# modprobe firewire-ohci
Nov 12 14:28:39 Host kernel: [ 4393.803067] firewire_ohci 0000:01:00.0: added OHCI v1.10 device as card 1, 4 IR + 8 IT contexts, quirks 0x11
Nov 12 14:28:39 Host kernel: [ 4394.306345] firewire_core 0000:01:00.0: created device fw0: GUID 008f1300d7ad1100, S400

EDIT #2

My user is in these groups:

uid=1000(user) gid=1000(user) groups=1000(user),6(disk),39(video),983(vboxusers)

Same error applies if I run Kino as "root".

And:

user@Host ~]$ sudo modprobe dv1394
[sudo] password for user: 
modprobe: FATAL: Module dv1394 not found.

EDIT #3

Is this a clue, if so, could someone help me use it to solve this?

Re comment 61:
> Now i do not know what are the implications of unblocking the firewire-ohci, but
> that was the solution that made my kino/kdenlive worked beautifully....

The implication is that you switched from
    ohci1394 + ieee1394 + raw1394 ( /dev/raw1394 ) --- libraw1394 + libiec61883 + kino
to
    firewire-ohci + firewire-core ( /dev/fw* ) --- libraw1394 + libiec61883 + kino
i.e. to different newer FireWire kernel drivers and a different character device file interface. This is basically what the blueprint "Enable new Firewire stack in default kernel config" is about. (See box at the right side of this page.)

The new kernel drivers are simpler, better performing, more compliant to specifications, and more secure than the older drivers. In contrast to Ubuntu's raw1394 access policy, firewire-core's device files are created with more liberal access permissions for devices which need to be (and are safe to be) accessed by userspace programs such as kino.

Sounds abit like my configuration, with the same modules and the same device names.

Source^

I also found this, but I can't figure out if this helps me.


Here is the Firmware:

[root@Host folder]# lspci -nn | grep 1394
01:00.0 FireWire (IEEE 1394) [0c00]: VIA Technologies, Inc. VT6315 Series Firewire Controller [1106:3403]

and here is:

[root@Host folder]# ls -l /dev/fw*
crw-rw----. 1 root video 249, 0 Nov 12 15:39 /dev/fw0
1

The pseudo device /dev/raw1394 may have some restricted acces permissions. Check with ls -l /dev/raw1394 to check ; maybe /dev/raw1394 rely on group like "video" ?

If you don't have the pseudo device, it means no driver has been loaded to handle the camcorder. try to see what's happend when connecting it :

  • disconnect the device
  • type tail -f /var/log/message to read the system log
  • connect the device

You should see what kind of device is detected by the firewire layer, and which driver is loaded to handle it, if any is available.

If nothing loads, you can try to insert them manually :

  • sudo modprobe firewire-core
  • sudo modprobe firewire-ohci

If the pseudo device still not exists, you can create it by hand :

mknod /dev/raw1394 c 171 0
8
  • Yea I recall something about this, I then added my user to the Video group, but this device does not exist on my system:/dev/raw1394 Nov 12 '14 at 13:28
  • I also updated the post. Maybe you need to manually load the modules, because hotplug may not work on firewire or with your device
    – Arcadien
    Nov 12 '14 at 13:50
  • No that doesn't do it, when I run your modprobe commands, they don't return errors but when I run lsmod | grep firewire-core and lsmod | grep firewire-ohci, afterwards nothing is returned. Nov 12 '14 at 13:59
  • weird.. could you 1. rmmod them, 2. paste the /var/log/syslog messages appearing when you load them?
    – Arcadien
    Nov 12 '14 at 14:00
  • There is a typo error in "rmmod firewire-ochi", which should be "rmmod firewire-ohci" :)
    – Arcadien
    Nov 12 '14 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.