0

Upgraded tomcat 6 to 8 on Centos 7.

I get this error in logs:
/usr/local/ctera/apache-tomcat-8.0.14/bin/catalina.sh: line 421: -Djava.endorsed.dirs=/usr/local/ctera/apache-tomcat-8.0.14/endorsed: No such file or directory

This is the only entry in logs...

This directory didn't exist, so I created it, with permission 777. Still get same error.

Tomcat 6 did not produce such an error.

I read a little about the endorsed directory - http://tomcat.apache.org/tomcat-8.0-doc/class-loader-howto.html and it shouldn't be a critical issue, but it is.
What should I do..?

0

RUNNING.txt provides a description of the endorsed directory:

Libraries that override standard "Endorsed Standards" libraries provided by JRE. See Classloading documentation in the User Guide for details. By default this "endorsed" directory is absent.

It should be safe to ignore, though I suspect JAVA_ENDORSED_DIRS is defined somewhere to point to that PATH. Is that a relative PATH to your installation?

0

There is a difference between tomcat 6 and tomcat 8 catalina.sh java process initiation.

In my case the problem was NOT in the endorsed directory, but in setting a different parameter before the endorsed dir, that included spaces, adding \ before them solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.