1

I'm trying to "bridge" a ricoh laser printer to the rest of my network with a freebsd box, I have some other services running on there, such as mediatomb and have been using it as a file/media server. My goal is to have my freebsd box "transparently" share my printer to the rest of my network while still functioning as my file/media server.

I have it setup like this:

Printer------[ethernet cable]------FreeBSDbox----[wifi]-----router

I set up bridging as shown in the handbook between the ethernet interface rl0 and my wireless interface at wlan0 (and added the necessary lines to /etc/rc.conf) However, now I am unable to ssh into my freebsd box even though it still shows up on the network.
What am I doing wrong?

  • Edit your question, copy-paste the lines in your /etc/rc.conf and any other relevant configuration. – Gilles Nov 12 '14 at 22:36
  • I would but the machine is far away and I am unable to ssh into it. I will see what I can do. – John Cooper Nov 13 '14 at 2:45
  • You probably just need to enable sshd in order to be able to ssh in. As for the printer, that's a bit more work. I think you'll need to at least enable packet forwarding, though I'd need more info to be able to tell you exactly what is needed. – Steve Wills Nov 15 '14 at 2:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.