5

I used to edit the settings in etc/conf/httpd.conf for better memory performance

<IfModule prefork.c>
StartServers       2
MinSpareServers    3
MaxSpareServers    3
ServerLimit       15
MaxClients        15
MaxRequestsPerChild  1000
</IfModule>

Now on 64bit Centos 7 there is no settings for this in httpd.conf only in /etc/conf.modules.d/10-php.conf :

<IfModule prefork.c>
  LoadModule php5_module modules/libphp5.so
</IfModule>

So how is the same thing achieved with this new set up in Centos 7?

  • I wonder if there is an RPM you need to install. Try executing sudo yum provides "*/libphp5.so" to see if there is an RPM that you could install. – Red Cricket Nov 12 '14 at 4:43
  • Edit 10-php.conf and add them there. Or am I miss-understanding your question? – garethTheRed Nov 12 '14 at 6:42
  • Red Cricket, executed that command and gives two libraries one of them php-embedded-5.4.16-23.el7_0.3.x86_64 : PHP library for embedding applications – cea Nov 12 '14 at 8:55
  • garethTheRed trying to work out which file controls these settings, if any in centos 7 and if not why. – cea Nov 12 '14 at 8:57
  • As almost an aside, please don't mod the httpd.conf file if you can. If you understand the update process around config files, and understand that some updates are security-driven changes to tunables in the configs (helloooo sudo) then you'll want to preserve the ability for RPM to update config files without lying about it and leaving you vulnerable. Forwarned! – user2066657 May 28 '18 at 23:25
1

create a file httpd-mpm.conf in the conf.modules.d folder and set your values there. the file is missing in binary, but available in httpd source package: http://www.linuxquestions.org/questions/linux-server-73/tunning-apache-but-setting-not-found-4175531918/

  • Actually, the httpd-mpm.conf file can be created in /etc/httpd/conf.d/ as well. The conf.modules.d folder is just a bit of a hack toward sorting and gathering the loadmodule statements together. – user2066657 May 28 '18 at 23:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.