1

I have set some email server(postfix with tsl3) and i have reach the goal to remove ssl2 from it,but thunderbird works perfect,mailx no. I did

echo prova|mail -S smtp-use-starttls user@domain

and all mail are bounced

said: 530 5.7.0 Must issue a STARTTLS command first (in reply to MAIL FROM command))
I use this configuration
master.cf

smtp      inet  n       -       n       -       -       smtpd
    -o smtpd_sasl_auth_enable=yes
    -o smtpd_enforce_tls=yes
    -o smtpd_client_restrictions=permit_sasl_authenticated,permit_mynetworks,reject

main.cf

smtpd_sender_restrictions =
    permit_sasl_authenticated,
    permit_mynetworks,
    reject_non_fqdn_sender,
    reject_sender_login_mismatch,
    reject_authenticated_sender_login_mismatch,
    reject_unauthenticated_sender_login_mismatch,
    reject

# TLS parameters
smtp_use_tls=yes
smtpd_use_tls=yes
smtpd_tls_received_header = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_auth_only = no
smtpd_tls_CAfile = /etc/ssl/certs/domain.local.crt
smtpd_tls_cert_file=/etc/ssl/certs/slackware.domain.local.crt
smtpd_tls_key_file=/etc/ssl/private/slackware.domain.local.key
smtpd_tls_mandatory_ciphers = high
smtpd_tls_mandatory_exclude_ciphers = aNULL, MD5
smtpd_tls_mandatory_protocols = SSLv3

Thunderbird ok,but mailx no,i try

mail -S smtp-use-starttls

Of course mail is linked with ssl.

0

Solution found

On main.cf

smtpd_tls_mandatory_protocols = !SSLv2, !SSLv3
smtpd_tls_protocols = !SSLv2, !SSLv3
smtp_tls_mandatory_protocols = !SSLv2, !SSLv3
smtp_tls_protocols = !SSLv2, !SSLv3

on master.cf

smtp      inet  n       -       n       -       -       smtpd
    -o smtpd_sasl_auth_enable=yes
    -o smtpd_client_restrictions=permit_sasl_authenticated,permit_mynetworks,reject

Ssl3 and 2 disabled and mail received

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.