So after I upgraded my MBP to Yosemite, I have lost dualboot. After a long struggle, I finally reinstalled refind to work properly. Unfortuantelly, when I use Ubuntu, I cannot access Macintosh HD drive anymore...The error I get when I try to acce Is anyone having a same problem? If so, is there a way to fix it?

  • 2
    Is hfsplus compiled into your kernel? – eyoung100 Nov 10 '14 at 20:36
  • 2
    Could you please add the messages from dmesg and possibly the error output when you try to run the mount command from command line? – pabouk Nov 10 '14 at 21:01
  • sudo apt-get install hfsplus libhfsp0 libguestfs-hfsplus hfsprogs hfsutils – mchid Nov 14 '14 at 5:59

First, if you intend to write to the HFS partition from Ubuntu, you need to disable journaling on your Mac

On your Ubuntu install hfsprogs tools

sudo apt-get install hfsprogs hfsplus libhfsp0 libguestfs-hfsplus hfsutils

Check your partition as montioned @Adam Zahran :

sudo fsck.hfsplus -f /dev/sdXY

Mount Mac partition:

sudo mkdir /mnt/your_mount_point
sudo mount -t hfsplus -o force,rw /dev/sdXY /mnt/your_mount_point
| improve this answer | |
  • 1
    This is the right answer. – Christopher Oct 26 '16 at 16:45

The same thing happened to me, I ran:

sudo fsck.hfsplus -f /dev/sda2

and then tried again and it worked perfectly.

Note: You should replace /dev/sda2 to whatever corresponds to your Macintosh partition.

| improve this answer | |
  • 3
    Is that safe? Could that cause issues macos? – DarkHeart Jul 5 '16 at 2:32
  • Never caused issues to me. But I don't understand what exactly the command does. So I wouldn't claim to know if it's completely safe under all circumstances. But then again, it worked perfectly fine for me causing no issues. – Adam Zahran Jul 5 '16 at 6:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.