3

The application switcher is no longer switching backwards with Shift+Alt+Tab. It does switch backwards with Shift+Super+Tab. I am using the alternative Alt-Tab extension. I tried disabling it but nothing changed.

When trying to set the shortcut in the Keyboard Shortcuts dialog box to Alt+TAB, I get the following message:

The "Switch windows of an application" shortcut has an associated "Switch to previous window of an application" shortcut. Do you want to automatically set it to "Shift+Alt+TAB"?

dconf editor under org/gnome/desktop/wm/keybindings has two entries:

switch-applications = ['<Super>Tab', '<Alt>Tab']  
switch-applications-backward = ['<Shift><Super>Tab', '<Shift><Alt>Tab']

How do I restore the original behaviour?

3
  • I tried that but there was no change. Furthermore, switch-applications may not be the same as switch-windows. There's no such entry in dconf-editor though.
    – To Do
    Commented Nov 10, 2014 at 17:29
  • I checked again dconf-editor and now there are entries for switch-windows and switch-windows-backward and they're set to Alt+Tab and Shift+Alt+Tab.
    – To Do
    Commented Nov 11, 2014 at 8:10
  • Hi, it turns out this is due to a non-gnome settings for xkb overriding it. See askubuntu.com/questions/1396900/…
    – oligofren
    Commented Mar 10, 2022 at 11:31

2 Answers 2

1

I had the same issue and found that (as stated in the question's comments) there are the following four entries related to this:

  • switch-applications: Alt+Tab, Super+Tab
  • switch-applications-backward: Alt+Shift+Tab, Super+Shift+Tab
  • switch-windows: Alt+Tab
  • switch-windows-backward: Alt+Shift+Tab

After removing the values from the switch-windows entries, Alt+Tab and Alt+Shift+Tab were working fine again.

Not sure what set them in the first place tough.

1
  • "Not sure what set them in the first place" - According to dconf, it's default for both Super and Tab to switch by application, not window, despite that most would expect Tab to switch by window. I think that's just GNOME enforcing a paradigm that disagrees not only with users' intuition but also, hilariously, their own defaults elsewhere - i.e. in Keyboard. I changed them to what IMO they should be - and what Keyboard implies misleadingly they are: switch_applications* with Super, and switch-windows* with Tab. Now keys actually do what Keyboard says they will. Incredible! Thanks, GNOME. Commented Jul 8, 2016 at 19:07
0

This issue is probably caused by a setting for XKB, which overrides the other Gnome keyboard settings. You can check out the background story here, but essentially clearing the settings fixes this:

See the value messing it up:

$ gsettings get org.gnome.desktop.input-sources xkb-options
['grp:alt_shift_toggle', 'grp_led:scroll']

Clear it to regain Alt-Shift for other uses:

$ gsettings reset org.gnome.desktop.input-sources xkb-options

$ gsettings get org.gnome.desktop.input-sources xkb-options
@as []

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .