1

I recently installed Ubuntu 14.04 on a computer with a Broadcom BCM4312 802.11b/g LP-PHY wireless card. After installing the proprietary drivers available from the Ubuntu repositories, I was able to see other wifis (my neighbours') APs, but not mine. I tried several drivers without success. I decided then to try Fedora, but after installing kmod-wl from the RPM Fusion repositories, I found the same problem. Of course, I also tried rebooting and resetting the router many times between installations and configuration changes...

The strange thing is that I am able to connect to the router from a different computer and from a mobile phone, but still I can't see the router's ESSID from this computer with the BC card, while I do see my neighbours' ESSIDs. What could be the problem?

1

Although searching on the internet will lead you to instructions like: reboot/reset your router, reinstall "this" or "that" driver version or make sure your ESSID is not configured to be hidden, the problem may be the channel.

Having a look at the 2.4 GHz (802.11b/g/n) specification (my router can only use de 2.4 GHz band), it seems that countries apply their own regulations and, although most of the world use channels 1 to 11 (frequencies between 2412 and 2462 MHz) some (as in North America), do not use channels 12 and 13. Japan, for example, uses channel 14 too, at 2484 MHz.

enter image description here

So, before giving up, try to change the channel configuration in your router and use one in the [1, 11] range and see if it works. In my case, the channel was set to "Auto", but the router was always selecting 13. If the new channel works, it is a good sign.

Now, you can just keep that channel configuration in your router or you can try and see if you have the correct configuration in your computer. Make sure the iwlist chan command lists the channel you want to use:

# iwlist chan
  [...]
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz
          Channel 14 : 2.484 GHz
  [...]

If it does not, then you may need to change the regulatory domain configuration with the iw command:

iw reg set XX

Where XX would be the ISO 3166-1 alpha-2 country code, or 00 as a special non-alpha2 usable entry for World Regulatory domain.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.