3

I've been struggling with installing Solaris 8 Sparc-32bit on Qemu for a while. So far I've viewed several sites with instructions on how to install Solaris-sparc32bit on Qemu. But only yesterday was I successful. Anyway, I downloaded and compiled the latest (3 weeks ago) of Qemu and obtained the ISO of Solaris 8 from my friend.

Using the command: sparc-softmmu/qemu-system-sparc -M SS-5 -bios ss5.bin -hda HDD/sunos8.img -m 256 -nographic

I was able to successfully install Solaris8.

I used this command to start the installation:

sparc-softmmu/qemu-system-sparc -M SS-5 -hda HDD/sunos8.img

The problem is the OS does not boot up as it should. When I run the above command here's the output that i receive:

VNC server running on '::1:5900'

Then I use TigerVNC to view using the command:

vncviewer localhost:5900

After that I get the QEMU gui. Here's a sample of the initial output:

Welcome to OpenBIOS v1.1 built on Mar 10 2014
 Type 'help' for detailed information
Trying disk...
SunOS Release 5.8 Version Generic_108528-22 32-bit
Copyright 1983-2003 Sun Microsystems, Inc.
Hostname: localhost
The /file system (dev/rdsk/c0t0d0s0) is being checked.
dev/rdsk/c0t0d0s0: INCORRECT BLOCK COUNT I=17266 (2 SHOULD BE 0) (CORRECTED)
dev/rdsk/c0t0d0s0: 39877 DUP I=17356
dev/rdsk/c0t0d0s0: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.

WARNING - Unable to repair the / filesystem. Run fsck
manually (fsck -F ufs dev/rdsk/c0t0d0s0). Eit the shell when
done to continue the boot process

Here's an image: enter image description here

The command prompt ask the user to press Return and the system will reboot. However, after pressing return the system just prints out a single line error message forever (basically like a loop that runs forever). So I don't have a chance to see the error line and post it here.

PLEASE Help!

Machine/Method: Windows 7 64-bit, Xeon (8-core), 6 Gig ram, Nvidia Quadro FX 1800 Running Scientific Linux 64-bit in VmWare (VmWare tools installed) I updated Scientific Linux before compiling Qemu

2

When you started your installed HD image, you didn't add -bios ss5.bin to the command line like you did during the installation and also you didn't add -nographic.

This means QEMU would have used OpenBIOS instead of the Sun OBP ROM used for the installation which have different device trees that may confuse the OS. I would highly recommend sticking with one particular ROM for both installation and use.

If you want a graphical console with the Sun OBP ROM image then you need to boot like this:

sparc-softmmu/qemu-system-sparc -M SS-5 \
    -bios ss5.bin -hda HDD/sunos8.img \
    -m 256 -g 1024x768 -vga cg3

That should get you a plain framebuffer which is enough to boot into the Solaris 8 XWindows installer.

I believe the issue with Java not starting is until under investigation.

  • Mark and goldilocks thanks for the suggestion. I know in the line that I typed I didn't specify the bios. However, whether or not OpenBIOS or Sun OBP ROM is used the installation does not boot. I've been dealing with this issue for a long time. I've tried several commands using the 'ss5.bin' file. Still doesn't bootup. In fact, when I use the command you suggested I get the same error all the time. Basically, after entering the command in a terminal I get to the Qemu prompt and type: 'boot disk0' (I'm assuming that disk0 is the HDD). 20 seconds after executing that command the system restarts. – Dean Masters Nov 10 '14 at 19:48
  • Alright going back to basics, the first thing to notice is that your disk image is claiming to be corrupt on first boot which is why you are seeing a lot of the problems. Solaris is quite fussy about disk partioning, and there are various guides as to how to do this - which one did you use? – Mark Nov 10 '14 at 22:35
  • You asked: "Which one did you use?". I used the sparc-softmmu/qemu-system-sparc -M SS-5 -bios ss5.bin -hda HDD/sunos8.img -m 256 -nographic. I decided to restart this whole procedure by installing Solaris9 instead. I used this command sparc-softmmu/qemu-system-sparc -bios ss5.bin -hda HDD/sunos8a.img -cdrom SolarisTest/sol9v1.iso -m 256 -nographic I eliminated the -M SS-5 option because, and I don't know why, the Qemu would restart itself. This happened many times without any error message. I'm currently in the middle of Solaris9 installation. I'll update you once it's finished. – Dean Masters Nov 20 '14 at 21:55
  • Sorry for not explaining better, but for "which one did you use?" I meant the disk partitioning setup. As recently as last week, I used the guide at virtuallyfun.superglobalmegacorp.com/?p=281 to prepare and label a 36G disk and installed Solaris 8 into it. After a reboot the disk was picked up correctly with no errors, and I was even able to run X (note: I am currently running a QEMU 2.2-rc2 on Linux) – Mark Nov 21 '14 at 18:13
  • Hi Mark, thanks for the reply. ---IN Qemu---> AVAILABLE DRIVE TYPES: 0. Auto configure 1. Quantum ProDrive 80S 2. Quantum ProDrive 105S 3. CDC Wren IV 94171-344 4. SUN0104 5. SUN0207 6. SUN0327 7. SUN0340 8. SUN0424 9. SUN0535 10. SUN0669 11. SUN1.0G 12. SUN1.05 13. SUN1.3G 14. SUN2.1G 15. SUN2.9G 16. Zip 100 17. Zip 250 18. other Specify disk type (enter its number): 15 selecting c0t0d0 (I created a 3G disk, so I picked #15) @Mark – Dean Masters Nov 21 '14 at 18:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.