5

I am helping a friend to recover data from damage external hard drive .

(USB 2, 120GB, WD, single partition, FAT32)

Problem:

When plug in this HDD into a windows PC, the HDD can be detected, but the drive did not show up. Checked using 'Disk Management', Found 'Disk 1' and shows that Disk 1 is not initialized.

1st Attempt:

Tried the 'Freezer trick' twice.

First time: manage to view the drive for 5 seconds, tried to copy all files, it stuck there after press Ctrl+C.

Second time: No luck, back to Not Initialized condition.

2nd Attempt:

After browsing through few article, I decided to try Ubuntu for the first time.

I am running Ubuntu on a DVD disk. After boot up the system, the external drive is not mounted. Through some trial and error using Terminal, I manage to find out that:

/dev/sda is my laptop HDD (750GB, with multiple drive)

/dev/sdb is the external HDD (120GB, Damaged drive)

At first, I try to use Testdisk 6.14 to recover data, but due to the external HDD is not mounted, Testdisk unable to detect it.

So I tried to mount it using Command in Terminal:

sudo mount /dev/sdb /media/ubuntu -t ext2

Result:

mount: wrong fs type, bad option, bad superblock on /dev/sdb, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so

Then I tried

dmesg | tail

Message (*) shows

[33935.683953] sd 6:0:0:0: [sdb]  
[33935.683954] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[33935.683955] sd 6:0:0:0: [sdb]  
[33935.683956] Sense Key : Medium Error [current] 
[33935.683958] sd 6:0:0:0: [sdb]  
[33935.683959] Add. Sense: Unrecovered read error
[33935.683960] sd 6:0:0:0: [sdb] CDB: 
[33935.683961] Read(10): 28 00 00 00 00 02 00 00 02 00
[33935.683965] end_request: critical medium error, dev sdb, sector 2
[33935.683991] EXT4-fs (sdb): unable to read superblock

Question:

  1. What is the meaning of Message (*)?

  2. Is the data in this HDD still recoverable?

  3. What should I do next?

1

The sense key "medium error" is feedback from the SMART system on the drive.

You can try smartctl -a /dev/yourdrive to get more information, but to me it already looks like the drive is fried. Replace it and restore data from backup.

If you don't have a backup a data recovery expert can help you, they do tricks like changing the HDD medium into other hardware, which you should not try to do at home.

1

In the second attempt you're trying to mount the drive as an ext2 filesystem...to mount as fat use the -t vfat option.

You can also try to image the drive with dd like dd if=/dev/hdx of=/path/to/image and then mount the image.

protected by Community Sep 11 '15 at 14:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.