1

I have such boot sequence: system boots from external disk, right after start it asks about password for LVM encrypted partition (which holds /root and /home), I enter it, the partitions are mounted, boot continues, everybody happy.

This was openSUSE 11.4. I upgraded to 13.2 and now the boot loader (grub) does not ask about any password, it believes that LVM mount point is regular, accessible partition, and after some delay it simply states this partition is not present (/dev/my_lvm/root).

I kept backup of old /boot and I compared device map of grub, and menu list, both version (previous, from OS 11.4) and current looks the same (actually analogous, because now grub has current and previous menu entries).

So how to make grub to ask me about the password, as before?

Update Using the info provided in the thread about boot loaders -- https://askubuntu.com/questions/107440/how-to-check-what-bootloader-my-system-is-using -- I have GRUB version 0.97 in my boot partition used.

  • Was it really Grub that was asking for the dmcrypt password, and not the initramfs? – Gilles Nov 7 '14 at 1:46
  • @Gilles, could be, I don't know, I asked about grub, because it was the boot loader for sure (no other boot loader was installed for 11.4). OS 13.2 installed 2 other boot loaders in parallel, but I hope (judging by the look) it is grub that still boots the computer. – greenoldman Nov 7 '14 at 6:24
3

I had a similar problem, installing openSuSE 13.2 x86_64 from scratch, using a boot partition and an encrypted LVM containing root and swap. (Side note: It's not easy to do that actually since when creating an lvm partition the installer UI will not even let you chose "encrypt this device", you can "ungrey" the checkbox however by first chosing "format partition" with anything else but btrfs, then go back to "do not format this partition" and selecting lvm, the checkbox is now clickable and it also really DOES encrypt it... kinda buggy UI but the logic works).

So, here's how i booted my system again after 5 hours of reinstallations etc: In grub, select other boot options and go "failsafe". You get a more down-to-earth boot with the typical oldskool-text scrolling down about what's happening... It will stop at some point and ask for the password for the disk (since it is multithreaded the prompt might actually not be the last line). Once you start typing the prompt reappears and you see * for each password letter entered. Note that contrary to 13.1 where only US keyboard layout was supported at the password prompt, the password prompt now uses the keyboard layout selected at installation time (or in yast presumably, if you ever changed it after installation).

So that's how I booted it, then I installed all updates and rebooted (STILL same problem!), got it up via failsafe again and went to YaST -> Boot loader. There, I removed the "splash=silent" option from the "regular" boot entry. Also, I do not know if it matters, but I am using normal GRUB2 not the GRUB2uefi, however, that will only work if your bios supports a non-uefi setting.

So this is not a fix (you do not get the graphical password prompt back) but you can boot with the "normal" boot entry.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.