2

The bash/zsh commandline prompt is not displaying colors in tmux, even though I managed to get the powerline itself working (with colors).

The prompt works fine in pure bash/zsh.

I am getting the proper output, only the colors are not displayed.

I have

set -g default-terminal "xterm-256color"

in my .tmux.conf

Additionally, I have

"term_truecolor": "true"

changing that to false did not make a differrence.

I read through the documentation, and it seems that setting

 additional_escapes to "tmux" or "screen"

should help. With "tmux" I am getting colors, but also some undesired spaces and ] characters in the prompt.

I also tried setting "screen-256color" or running tmux with -2 option. Any ideas?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.