3

I'm not an expert on computers in general or Linux in particular, so if I'm vague on something please let me know and I'll try to elaborate.

I have an old computer running Red Hat 5.0. It had a Windows dual-boot (98 or XP - I forget which), but I never used it much and a few years ago when it said it was corrupted I threw up my hands and said good riddance. However, I believe it also had some version of Fedora and maybe something else. I say maybe, because I seem to be locked out of the boot menu.

After it boots up, it hangs for 4 seconds saying something like, "Press any key for options." Ordinarily, I'd be able to press a key and choose my OS. Today, however, I pushed a key and nothing happened. It did its typical sequence 3, 2, 1, then booted normally.

I tried rebooting a couple times, and the same thing happened. My questions are these:

Is there something I've screwed up somewhere that's causing this? Or is it probably just something to do with an ancient machine? Is there some sort of troubleshooting I can do to check for corruption?

Is there a way to restart my computer and boot it from a CD or DVD directly, e.g. terminal command? That's what I was trying to do originally when I found the problem.

Thanks!

1

You can reboot the computer with a terminal command, but you can't give it a terminal command that tells it what device to reboot into. Once the machine reboots control is passed to the BIOS, which then decides what device to boot from.

Some BIOSes will automatically offer to boot from a bootable CD/DVD if it detects one, but not all.

So when the machine starts (or restarts) you need to press whatever key your BIOS recognises as the BIOS boot menu key, if it has one. Failing that, you need to press the key which lets you get into the BIOS setup so you can select the bootable devices and the boot order. It's a Good Idea to make a CD / DVD drive the first bootable device.


To be somewhat vaguely on-topic, I guess I should've mentioned the terminal command(s) used to reboot. :) Check out the man pages for shutdown and halt, the halt man page also mentions its synonyms reboot and poweroff.

...

I suppose corruption on your hard drive(s) could be stopping you from booting the various bootable partitions on the system, but at this stage I'm more inclined to think the problem is BIOS-related.

If you haven't done so already, take the machine apart and give it a good clean. Remove the RAM cards from their slots and make sure there's no corrosion on the connectors - a pencil eraser can be used to remove minor corrosion spots. A tiny bit of solvent (like rubbing alcohol) on a cotton bud (Q Tip) may be necessary for more stubborn spots. Do the same with any other removable cards. As I mentioned in the comments, it's probably a good idea to replace the CMOS battery.

To test that your RAM is healthy, run memtest (aka memtest86 or memtst86). It's probably already installed, and is generally included on any Linux live CD /DVD (maybe in the boot/ directory).

If you suspect there's a problem with your hard drive partitions, run fsck on them. And you may also like to use the badblocks program. See their man pages for details, but if anything is unclear, please ask.

| improve this answer | |
  • I guess I should have clarified. It won't let me into the BIOS either. From the time it powers up to the login screen I'm completely unable to intervene. If I could get into the BIOS it would be easy.... – Sigma - check out Codidact Nov 5 '14 at 3:08
  • Are you pressing the right key (determined by the motherboard vendor) to get into the BIOS settings during the reboot process? – mdpc Nov 5 '14 at 7:02
  • @Sigma: Yikes! We're getting somewhat off-topic here, but anyway... Try resetting you BIOS to the default settings - there should be a jumper on the motherboard near the BIOS CMOS battery, if not, remove the battery for a few minutes. And since the machine's been in limbo for a few years it may be worthwhile replacing that battery. – PM 2Ring Nov 5 '14 at 11:14
  • @Sigma: If that doesn't let you get into the BIOS, disconnect all your hard drives (either the data cables &/or the power cables) - that'll stop it booting! :) And hopefully you'll be able to get into the BIOS setup, it may even do it automatically. With no hard drives connected you may not be able to play with any boot order settings, but at least you'll be able to look at the current BIOS settings to make sure they're sane and you'll be able to force the BIOS to use its default settings. – PM 2Ring Nov 5 '14 at 11:18
  • Resetting the BIOS worked perfectly - thank you so much! – Sigma - check out Codidact Nov 5 '14 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.