1

Every time I use xfreerdp on Mint 17 to connect to a Windows Server 2003 box, it gives the successful "connected" line identically three times before launching the window:

$ xfreerdp (mycommandlineargshere)
connected to (myhostnamehere)
connected to (myhostnamehere)
connected to (myhostnamehere)

Why?

I tried strace once to a file, hitting Ctrl+C between the third connected to and before the window actually opened. Then I tried it again, but quickly hit Ctrl+C after the first connected to. I compared the files, and besides differing memory addresses, they appear identical, with the same number of lines and the exact same file size, down to the byte. I suppose then that we can conclude the latter two connected to statements occur without any strace output.

  • 2
    Can you show an example? Also prefixing it with strace -s 2000 -o my.log ... will give you further insights. – slm Nov 4 '14 at 18:47
  • @slm not sure how an example helps, but there it is. Will try strace, thanks – Kev Nov 5 '14 at 17:17
  • @slm I'm not willing to post the log because of the detail it contains. I don't see anything that occurs exactly three times. What am I looking for? – Kev Nov 5 '14 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.