2

My recent upgrade to Jessie removed gcc-4.7 from my system and install gcc-4.8 on the box. The problem is that I need the former one.

Can anyone explain me why these two versions conflict in Debian? Is there any technical reason behind it that would justify this. My project requires painful path to be compilable by gcc-4.8?

Is there a safe way to install gcc-4.7 in parallel to gcc-4.8 (compilation is not a option - it has to be a Debian package)?

4
  • 2
    I have both 4.7 and 4.9 installed on my Wheezy system. Afaik, these packages can co-exist, and there is no conflict. I suggest installing gcc 4.7 from unstable, if it is not present in Jessie. If you have difficulties doing so, please elaborate in the question - not the comments. Commented Nov 4, 2014 at 13:19
  • I agree with Faheem. You can have multiple gcc's installed and they do not conflict. Have you tried simply reinstalling gcc-4.7? You will then have to invoke it by that name, and/or set $CC or change the /usr/bin/gcc symlink, etc.
    – goldilocks
    Commented Nov 4, 2014 at 14:13
  • @Faheem: I'm talking about 4.7 & 4.8 present at the same time. Not 4.7 & 4.9. When I want to install gcc-4.7, apt-get want to remove lot of stuff.
    – Michał F
    Commented Nov 5, 2014 at 12:06
  • @MichałF It really shouldn't make a difference. "apt-get want to remove lot of stuff." Details, please. Commented Nov 5, 2014 at 12:33

1 Answer 1

3

gcc-4.7 is not included into Debian Jessie (see https://bugs.debian.org/765379 ).

It is still in Debian unstable and does not conflict with anything. As Debian unstable and Debian Jessie are very similar at the moment (Nov 2014), you should not get any problems.

See e.g. https://wiki.debian.org/AptPreferences or this answer how to install packages from unstable into a testing system.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .