15

Sice a few days (I suspect since I have upgraded to gnome 3.14) on ArchLinux I can't print anymore. If I open the printing panel of gnome control center I get a message like (it's translated from Italian): "System service for printing seems not be available"

So from terminal I tryed:

$ sudo systemctl start cups
Failed to start cups.service: Unit cups.service failed to load: No such file or directory.

I also tried reinstalling cups but no luck. I also googled around and tried the various solutions proposed but none of them works for me.

34

As of cups v. 2.0.0 the service name has been changed . You'll have to disable the old service:

systemctl disable cups.service

before enabling and starting the new one:

systemctl enable org.cups.cupsd.service

systemctl daemon-reload

systemctl start org.cups.cupsd.service
  • Perfect! Thanks. It worked for me. The same problem as OP. – Marcin Nov 4 '14 at 10:28
2

I don't know whether you use the command line or a GUI to install updates, but the upgrade process did print the following lines (from the install file linked in the other reply) on the screen:

> systemd unit names have been renamed"
> you should systemctl stop and disable cups.service and"
> systemctl daemon-reload, start and enable org.cups.cupsd.service"

This is not meant as a slap on the fingers for not having read this, but more to make you aware that if you are using some sort of GUI to manage Arch updates, you may not get to see the output produced by pacman. If this is the case, you should strongly consider using a different update helper, or simply run pacman from the command line.

If you prefer using a GUI, you should consider kalu as it can also handle AUR upgrades, as well as display news updates from the Arch website which often contain vital information about updates that require manual intervention, such as the recent updates to Java and Intel microcode.

Please note that if you use any other service files that depend on cups.service, you may have to manually update those service files to rename cups.service to org.cups.cupsd.service. This is, for example, the case with the ccpd.service file provided with the Canon CAPT driver in the AUR.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.