2

I've been trying new color schemes and I set:

   colorscheme gotham256
   set background=dark
   set t_Co=256
   highlight Normal ctermbg=NONE
   highlight nonText ctermbg=NONE

but these thing doesn't work , actually these changing some color stuff but when I command manual like :set background=dark it works totally different.

For Instance I open new file my background doesn't change as set background=dark and my terminal default color stays.

If I command manually step by step like

colorscheme gotham256
set background=dark
set t_Co=256

It is working the way I want.

Why Is this happening and how can I solve this?

  • Do you source some other settings file after those lines? – Chris Down Nov 3 '14 at 17:42
  • I have some setting but they doesn't connected each other any way if you are asking this. – Vivian Maya Nov 3 '14 at 17:44
1

You need to edit your .vimrc like so with a colon before the commands

:colorscheme gotham256
:set background=dark
:set t_Co=256
:highlight Normal ctermbg=NONE
:highlight nonText ctermbg=NONE
  • 1
    This is not incorrect this fixed my problem thank you. – Vivian Maya Nov 3 '14 at 18:30
  • 1
    You are welcome! Some systems do not interpret the commands without a colon. My machine works both ways, but some do not. Glad I could help you fix your problem! – Christopher Stanley Nov 3 '14 at 18:35
  • @dotancohen why incorrect? it seems to work... – martin jakubik Jul 21 '16 at 9:07
  • I'm not sure to what I was referring to two years ago, probably to the colons, so I simply removed my comment. – dotancohen Jul 21 '16 at 9:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.