1

I'm importing my mini-dv tapes to my computer system, and I installed Kdenlive, and wanted to try it for the task. But it's complaining about a missing module that is already installed. Is this common? Is this a bug? What can I do to resolve this?

Here is kdenlive on the system:

[root@Hostname ~]$ yum list kdenlive 
Loaded plugins: fastestmirror, langpacks, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: www.fedora.is
 * rpmfusion-free: www.fedora.is
 * rpmfusion-free-updates: www.fedora.is
 * rpmfusion-nonfree: www.fedora.is
 * rpmfusion-nonfree-updates: www.fedora.is
 * updates: www.fedora.is
Installed Packages
kdenlive.x86_64                0.9.8-2.fc20                 @rpmfusion-free-updates

Here is the module installed, please tell me if it is not the right module:

[root@hostname folder]# yum list libdv
Loaded plugins: fastestmirror, langpacks, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: www.fedora.is
 * rpmfusion-free: www.fedora.is
 * rpmfusion-free-updates: www.fedora.is
 * rpmfusion-nonfree: www.fedora.is
 * rpmfusion-nonfree-updates: www.fedora.is
 * updates: www.fedora.is
Installed Packages
libdv.i686                          1.0.0-16.fc20                   
 @fedora  
libdv.x86_64                        1.0.0-16.fc20                   
 @anaconda

Here is the error: enter image description here

Here is my Firewire:

[root@Hostname folder]# lspci | grep -E "Firewire|1394|IEEE"
01:00.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6315 Series Firewire Controller

Here are my modules(new firewire stack):

[root@Hostname folder]# lsmod | egrep 'firewire|1394'
llc                    13941  2 stp,bridge
firewire_ohci          40502  0 
firewire_core          62559  1 firewire_ohci
crc_itu_t              12613  1 firewire_core

What is happening here?

My OS is Fedora 20 x86_64.

I'm starting an bounty for this one in one hour, 50 points reward. I would really like to have the ability to use an software suite like Kdenlive for importing/editing my dv's(I have also compiled Kino, but it complains about:WARNING: dv1394 kernel module not loaded or failure to read/write /dev/raw1394).

This works:

# dvgrab -a -format raw -rewind -t prefix-

for importing dv's from camcorder, so the firmwire modules are functioning, and it must be some really easy mod for kdenlive capture to work.

EDIT #1

I found out that I can use the software without that module, but I still would like to fix the missing module, and maybe get some info on it. If someone knows about this error, module and or fixes, please post an answer for this.

2
  • Is avformat installed? Read the error message again, and check that other tab.
    – eyoung100
    Nov 3 '14 at 16:22
  • @eyoung100 Hi, avformat is not found in either "yum search avformat nor yum list avformat", I have no idea what this package is, side note, I just tried to build from source "kino" and this is a similar error to this one I'm getting:No package 'libdv' found. As you can see in my question it's already installed. Nov 3 '14 at 16:32
2

There is a developer saying that the libdv module is deprecated in the later builds, here.

Excerpt:

A next thing I saw was in the configuration wizard that the DV module (libdv) is not checked (so not installed). But if I look in Synaptic then I see that libdv4 version 1.0.0-6 is installed.


(0010239)
pez4brian   (developer)
2014-08-16 17:42

    I committed a change to the build script which should fix the profile problem:
https://github.com/mltframework/mlt-scripts/commit/c8705edd820a1a5566b57fabca63b8637965d398 [^]
Please try again with tomorrow's daily build.

We have disabled libdv by default in the latest MLT because libav/ffmpeg support dv very well. libdv is now deprecated. My advice would be to remove the specifc libdv check from KDENLIVE.

I haven't looked at the audio issue yet. 

And here it is discussed by some users.

Excerpt:

Sun Oct 26, 2014 8:25 pm
hello
libdv has been disabled in MLT as libavcodec/format now include everything that libdv used to provide (and maybe more?).
we just should update the wizard to avoid the false warning.
(MLT mailing list is a good source of info in general, and especially these times: they are cleaning things and this induces notable changes)

Here is MLT Framework info on the module:

Excerpt: enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.