5

I run xubuntu 12.04 alongside a NTFS storage partition and a windows 8 partition.

I moved my MySQL data directory off the xubuntu (ext4) partition, onto the NTFS partition, and did an import of a database. I left it running overnight, and in the morning, I had a filesystem crash (everything was read-only). Now when I try to boot the computer, I am taken to grub rescue.

grub rescue> ls (hd0) (hd0,gpt8) (hd0,gpt7) (hd0,gpt6) (hd0,gpt5) (hd0,gpt4) (hd0,gpt3) (hd0,gpt2) (hd0,gpt1) (hd1)

I tried ls on all of these partitions, and all but two said error: unknown filesystem. The other two said:

grub rescue> ls (hd0,gpt8) error: invalid file name `'.

grub rescue> ls (hd0,gpt8)/ ./ ../ lost+found/ OS/ Downloads/ .Trash-1000/ ... <- promising, but only shows a subset of folders

grub rescue> ls (hd1) error: failure reading sector 0x0 from `hd1.'

Most of the other boot rescue posts on askubuntu are about failures during installation, so I'm not sure their advice to run boot-repair applies here.

Next steps?

2
  • I suggest booting from a CD / DVD / USB stick. You can run fsck from there if the partitions cannot be mounted. If you have a spare drive you may consider making a sector copy (dd) before running fsck. – Hauke Laging Nov 2 '14 at 21:29
  • I did, and took log of the errors, as well as a TestDisk, but I didn't get it onto the Live USB successfully. Oops. I will redo that and update tonight/tomorrow. – szxk Nov 3 '14 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.