0

I am trying to compile the TI-Graph Link USB Drivers? So I downloaded it, and ran make in the directory libusb. It produced the following:

~/Téléchargements/tiusb/tiusb-1.10$ make
make -C /lib/modules/`uname -r`/build SUBDIRS=`pwd` modules
make[1]: entrant dans le répertoire « /usr/src/linux-headers-3.13.0-031300-generic »
  CC [M]  /home/dovakhin/Téléchargements/tiusb/tiusb-1.10/tiusb.o
/home/dovakhin/Téléchargements/tiusb/tiusb-1.10/tiusb.c:36:28: erreur fatale: linux/smp_lock.h : Aucun fichier ou dossier de ce type
compilation terminée.
make[2]: *** [/home/dovakhin/Téléchargements/tiusb/tiusb-1.10/tiusb.o] Erreur 1
make[1]: *** [_module_/home/dovakhin/Téléchargements/tiusb/tiusb-1.10] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux-headers-3.13.0-031300-generic »
make: *** [tiusb.o] Erreur 2

So the fatal error is cannot find linux/smp_lock.h

I'd like to connect my TI 83 to my computer.

2
  • "You'll also need the sources of the running kernel, and these sources must be configured." do you?
    – Braiam
    Commented Nov 2, 2014 at 20:03
  • I think so I ran sudo apt-get sources linux or something like that. But firstly there is no such file and also, I dont know where to put them. It created a folder and a tar archive in the libusb folder (since terminal was there). In the folder there is the folder kernel, but what then? And lastly there are already a folder linux-header... in /usr/src
    – Vinz243
    Commented Nov 2, 2014 at 20:21

2 Answers 2

2

this is upstream. I've somehow found this topic through an unrelated search :)

The page where Braiam found the "It's intended to be used with kernel 2.4 & 2.6" information, http://lpg.ticalc.org/prj_usb/linux_download.html , correctly states "Note: driver is now longer maintained. Use built-in libusb support in ticables library."
All Linux drivers related to TI calculators produced by the LPG (tipar, tiser, tiusb) were superseded by user-space solutions, in the aforementioned libticables, years before I became the maintainer of the libti* family, in June 2009.

tipar was removed from mainline kernel by commits cb8c9b6de076d981ca22801dbd6bce12b0758468 (November 2007), 755271358cc401eb3db0db52b2c8fb8d71ae4d8f, f557d0996a6f9c06912528ea85e1dba0fb7d485f.

TILP II will enable you to your Linux computer through a SilverLink and a DirectLink. The standard install script for libti* + gfm + tilp is http://lpg.ticalc.org/prj_tilp/download/install_tilp.sh , it has worked for dozens of persons on multiple Linux distros over 5 years.
If your distro isn't Debian or one of its derivatives (Ubuntu, Mint, etc.), you need to edit the script to add --enable-libusb10 at the indicated place. Most other distros do no longer provide proper libusb 0.1 packages, only the 0.1 compat layer for libusb 1.0, which fails to work for the purposes of libticables.

1

Those drivers aren't intended for newer kernels:

It's intented to be used with kernel 2.4 & 2.6.

It's searching for a header that do not exist anymore in the kernel. You must contact developers so they can provide a patch.

2
  • No way to correct this myself?
    – Vinz243
    Commented Nov 2, 2014 at 21:03
  • @Vinz243 Contact the developers.
    – Braiam
    Commented Nov 2, 2014 at 21:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .