4

I have a Lenovo Thinkpad X240, and it works well and on normal temperatures. However, sometimes the fan does not start even when running high stress processes that warm up the CPU drastically. In these situations when I put the device to sleep and start it up again, everything goes back to normal, the fan starts and cools the CPU down quickly. How to investigate this problem? Can this be a hardware issue?

I am running Arch Linux and I have thermald enabled.

  • What happens if you don't sleep the system, but just reboot? Powering up out of sleep might include an extra voltage difference that nudges the fan into motion, something a reboot doesn't necessarily do. – Anthon Nov 2 '14 at 11:27
  • The reboot does have the same effect, and so does a shutdown + turn on. Also, when everything is normal, the fan starts easily on low speed as well. – kdani Nov 2 '14 at 13:15
  • 2
    Could this be a hardware issue? When very hot but fan not running, does it start if you slap it? (I'm not kidding!) In my 30 years of experience, fan issues account 90% of all computer hardware problems. They clog with dust easily and the lubrication thickens or dries out so they won't turn. If the fan starts when slapped, step #1 is to clean it. If that doesn't work, either oil the hub or replace it. – DocSalvager Nov 6 '14 at 20:37
  • @DocSalvager thanks a lot for your suggestions. Strangely, I can not reproduce the issue anymore after disabling thermald. The fan is probably not dirty, as the computer is really new. (Bough unused 2 weeks ago). However, my other guess would be a voltage problem, as Anthon suggested. I will try your suggestion if the problem can be reproduced. – kdani Nov 6 '14 at 22:21
  • 2
    worth trying Live Ubuntu CD and see how its behaving, it could be issue of ArchLinux because its very customizable OS – Satish Jan 6 '15 at 22:22
1

The problem that you are getting might be a hardware issue the same problem what you are facing now one of my friend got. Sometime his fan isn't running and sometimes it is working fine It was happening because of dust or may be a fan issue.

what I did to solve the issue.

First I cleaned it with blower gun then when it wasn't started then I slightly pushed the cpu fan with a needle (be careful while nudging remove the needle quickly) then the fan suddenly started and worked fine for few months.

after that he faced the same issue solved by replacing fan.

I think it will not be a OS issue. If it is the everytime you suspend your CPU fan should not start.

0

Check that your system firmware is entirely up-to-date. This sounds like an ACPI issue, which is not as well-tested on Linux as on Windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.