1

I have a Mac upgraded from Mavericks to Yosemite. When I tried to run VMware Fusion, I got an error stating:

Could not open /dev/vmmon: No such file or directory.
Please make sure that the kernel module `vmmon' is loaded.

A brief search turned up to say that this behavior happens when something else gloms on all the major and minor device numbers, so that VMware tries to get a device and doesn't find a number free.

There were suspects mentioned in the results, e.g. this VMware communities thread. Following this "retry, reboot, reinstall" recommendation did not change anything as far as I can tell.

I am not aware of anything that should be glomming on device remembers, and do not remember getting any such errors from VMware in the past.

How can I identify what is glomming on major and minor device numbers (if that is in fact the culprit)?

Thanks,

  • 1
    I see reports that vmware fusion 6.0.4 works on yosemite, but may be slow, and that version 7 works fine. 6.0.3 is reported to not work. What version do you have? – Mark Plotnick Nov 2 '14 at 7:55
  • 1
    I had 5.x; I upgraded to 7.x and that is working. – Christos Hayward Nov 3 '14 at 13:53
3

The VMWare application includes a kernel extension (kext). Yosemite requires a signed kernel extensions, and the older VMWare did not include a signed kernel extension. As a result, the old kernel extension will not load under Yosemite. You'll need to upgrade to VMWare Fusion 7, which includes the signed driver. It's unfortunate that you're forced to upgrade, but that resolved the issue for me.

Also, from another forum, the following solution (which I have not tried) may be of use:

  1. In Terminal, run:

sudo nvram boot-args="kext-dev-mode=1"

  1. Restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.