0

I'm having an issue with Apache 2.4.10 and PHP 5.6.2. Specifically, Apache has suffered from segmentation faults when I attempt to access certain files on my localhost through the browser (full details are here, in case anyone wants to check it out).

In an attempt to rectify the problem so I can actually get some work done, I'm trying to downgrade both my Apache and PHP to earlier versions. I'm using Mint 17, so I went through the package manager to remove the existing Apache 2.4.10 and PHP 5.6.2. I then removed the PPA that I got those packages from, and instead installed the dotdeb repo as it tends to be a few updates behind. When attempting to install Apache 2.4.7 from dotdeb, I get the following error:

enter image description here

How do I fix this? When I removed Apache 2.4.10, I marked it for complete removal. I'd think that would get rid of all the related packages/dependencies.

0

Solved by going through the package list and seeing that despite selecting 'Complete Removal' for Apache 2, several dependencies still remained. After removing those, I was able to install a downgraded version of Apache (2.4.7).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.