2

I have installed Qt 4.8.2 from Debian Wheezy on my system. Now, some application requires Qt 4.8.3 on my machine, so I looked at the versions and found that Qt 4.8.6 is avaliable in Wheezy-Backports:

# aptitude versions qt4-qmake:amd64
Paket qt4-qmake:                                                         
i A 4:4.8.2+dfsg-11             stable              900
p A 4:4.8.6+dfsg-2~bpo70+1      wheezy-backports    800 

I tried to upgrade the package qt4-qmake and hope that it will upgrade all other required packages via dependencies, but I get the following:

# aptitude install qt4-qmake:amd64/wheezy-backports
The following packages will be REMOVED:           
  qt4-qmake{u} 
0 packages updated, 0 additionaly installed, 1 will be removed and 0 not updated.
0 B of archives must be downloaded. After unpacking 5.030 kB will be free.
The following packages have broken dependencies:
 libqt4-dev : Requires: qt4-qmake (= 4:4.8.2+dfsg-11) But it shouldn't be installed.
The following actions will resolve the dependencies:

      Remove the following packages:             
1)      automoc                                       
2)      kdelibs5-dev                                  
3)      liblastfm-dev                                 
4)      libphonon-dev                                 
5)      libqca2-dev                                   
6)      libqt4-dev                                    
7)      libqt4-opengl-dev                             
8)      libqtwebkit-dev                               
9)      libqwtplot3d-qt4-dev                          
10)     libstrigiqtdbusclient-dev                     

      Leave the following dependencies broken:
11)     qt4-designer suggests libqt4-dev             
12)     qt4-dev-tools suggests libqt4-dev            


Accept this solution? [Y/n/q/?]

The output was translated from German, so it isn't aptitude's original output

After entering n, it goes along with removing packages, but it doesn't suggest any other updates.

Is there any way to make aptitude to update all the packages? Adding an libgt4-dev/wheezy-backports also doesn't help since this requires other packages to be upgraded.

0

With apt-get you do

apt-get install -t wheezy-backports qt4-qmake

I don't think the :amd64 is necessary, unless amd64 is not the standard arch for your machine. A similar syntax should work with aptitude in theory, i.e.

aptitude install -t wheezy-backports qt4-qmake

However, aptitude is inclined to be a bit wacky; I'm not a big fan of it. I'd use apt-get if I were you. The /wheezy-backports syntax is intended to make only the package marked like that installable. For backports you usually want -t wheezy-backports or similar (insert correct name of release).

Incidentally, you can get output in English. See e.g. Switch terminal output language from native language to english. Eric's answer will work, I think.

  • I added the :amd64 only because I get results to install the i386 package instead, but :amd64 only moves this result more to the back (I need to enter more n until I see it). And why does the command install qt5? – msrd0 Nov 1 '14 at 11:00
  • @msrd0 I'm sorry. I have no idea what either part of your comment means. Did you try the command I suggested? Did it work for you? If not, please post what errors you get. – Faheem Mitha Nov 1 '14 at 11:11
  • I tried your command for apt-get, and it says that it will update the packages, but also install qt5 and a whole bunch of other packages that I don't want/need – msrd0 Nov 1 '14 at 11:17
  • This command does indeed want to install a slew of packages, but qt5 is not among them, at least on my system. can you paste the command output for your system in your question, please? – Faheem Mitha Nov 1 '14 at 13:22
  • I have now installed all the packages, but here is the output (translated the important part): paste.debian.net/129714 – msrd0 Nov 1 '14 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.