3

When I try to install linux as dual boot on my laptop. However it does not show any available drives for me to install it on when I get to the install screen on a live boot cd.

I have tried creating a EXT and Fat32 partitions however its still not finding any drives..

This is what my windows partitions look like using the windows7 partition tool

admin tools windows 7

This is what the linux install shows

enter image description here

bios setting

The Laptop is a dell laptop. -- inspiron-14z http://www.dell.com/uk/business/p/inspiron-14z-5423/pd

  • Your laptop has an 8GB disk? – derobert Oct 30 '14 at 20:56
  • no that is the hibernate partition – Robbo_UK Oct 30 '14 at 21:01
  • 1
    Odd that Windows sees it as a separate disk, though. – derobert Oct 30 '14 at 21:15
  • just done this.. – Robbo_UK Nov 1 '14 at 23:55
6

I didn't want to disable Intel(R) Smart response Technology as it does offer performance improvement. Changing the BIOS to get rid of the raid setup would have done just this.

The bulk of my resolution came from this Super User answer here:

How do I install Windows 7 (with Intel RST) and Linux to dual boot on a Dell XPS 15?

Mine differed in a few ways though - mainly I used the Windows 7 bootloader and not the Linux grub one. Here are the steps I did.

I created some free space partitions using windows partition tool before booting into the Ubuntu live DVD.

Control Panel -> Type partition in the search -- open windows partition tool..

I created 100GB and 4GB. Then used the windows tool to keep the new partitions as unallocated. I then used Acronis disk manager partition tool to convert it to EXT3 and Linux swap (other free alternatives exists). I had to use the windows tool to make the space free first as the Aconis tool seemed to crash when I try to resize the C drive directly.

Next I disabled Intel smart response from the Windows task bar

right click -- options -- disable. (see screenshot below)  
You can enable it again after you have installed Linux.

disable intel smart response

I then re-booted my laptop and loaded Linux from the Live DVD disk.

When Linux booted up I typed in the terminal

modprobe dm_mod
dmraid -ay
ls -la /dev/mapper/

The above commands made the drives visible. After the commands I clicked the "install Linux". Then on the 'choose partition' sections I selected the one EXT3 one I created and set that as my Linux root. Then the 4GB and set that as the swap. I then installed Linux.

Upon restart it didn't boot straight into Linux - this is because I did not overwrite the Windows bootloader. Everything was installed only on the partitions I created. I was worried about messing it up and not being able to get into Windows.

To enable my laptop to load into Linux on this new setup - I booted it into Windows (it didn't give any other options at this point). Then in Windows I downloaded and installed EasyBCD. This is quite a handy tool as it allows you to add add additions to the Windows bootloader - you just select the partition. When I load my laptop now it allows me to load Linux or Windows 7 from the bootloader. After this was working I then re-enabled Intel smart response.

1

The question here is where exactly you want to install linux mint.

The only drive you can use to do that is your current C: drive. The problem is, that all of the space on it is currently being used by windows. What you need to do, is shrink that partition from within windows (No problem since currently 79% of it are not used) and once that space is freed up, you should be able to install linux mint without problems.

  • I have tried resizing the partition and creating free space... The linux installer does not find the drive. – Robbo_UK Nov 1 '14 at 23:48
  • Have you tried disabling UEFI/Secure Boot from your BIOS? Also check the SATA mode – Tico Nov 2 '14 at 3:03
  • sata raid options are ATA, AHCI, Intel(R) Smart response Technology.. Its on the intel one.. It warns me that by changing it I could lose all my data?.. I want to be able to dual boot into both of them. – Robbo_UK Nov 2 '14 at 14:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.