8

For the past 3 days (after an update) my Debian Jessie refuses to mount NTFS disks. I reinstalled libfuse2 and ntfs-3g, yet I get the same Input/output error

I tried the same disks under Windows 7 and OSX Mavericks (using ntfs-3g) and they work fine. I purged ntfs-3g and reinstalled, and still the same problem.

The disks will sometimes mount and sometimes won't mount. If they do mount, I am sometimes able to go into the mount directory, whereas some other times, I get a bash error Input/output error for the mount directory. The times I am able to go into the mount directory, when I try an ls -l, I see tons of question marks, instead of file/dir attributes.

I have tried ntfsfix and chkdisk under windows, and they both reported no problems, it is only under this Jessie install that all of a sudden I can't mount them properly.

dmesg has no usefull info other than the external disk being attached:

[12816.210969] scsi 20:0:0:0: Direct-Access     Seagate  External         SG16 PQ: 0 ANSI: 4
[12816.211825] sd 20:0:0:0: Attached scsi generic sg7 type 0
[12816.212542] sd 20:0:0:0: [sdg] 732566642 4096-byte logical blocks: (3.00 TB/2.72 TiB)
[12816.213591] sd 20:0:0:0: [sdg] Write Protect is off
[12816.213595] sd 20:0:0:0: [sdg] Mode Sense: bf 00 00 00
[12816.214782] sd 20:0:0:0: [sdg] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[12816.215561] sd 20:0:0:0: [sdg] 732566642 4096-byte logical blocks: (3.00 TB/2.72 TiB)
[12816.242055]  sdg: sdg1 sdg2
[12816.243244] sd 20:0:0:0: [sdg] 732566642 4096-byte logical blocks: (3.00 TB/2.72 TiB)
[12816.246031] sd 20:0:0:0: [sdg] Attached SCSI disk

parted /dev/sdg 'print'
Model: Seagate External (scsi)
Disk /dev/sdg: 3001GB
Sector size (logical/physical): 4096B/4096B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      258kB   1038GB  1038GB  primary
 2      1038GB  3001GB  1962GB  primary

fdisk -l /dev/sdg
Note: sector size is 4096 (not 512)

Disk /dev/sdg: 3000.6 GB, 3000592965632 bytes
255 heads, 63 sectors/track, 45600 cylinders, total 732566642 sectors
Units = sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00090a06

   Device Boot      Start         End      Blocks   Id  System
/dev/sdg1              63   253473569  1013894028    7  HPFS/NTFS/exFAT
/dev/sdg2       253473792   732566527  1916370944   83  Linux

mount -t ntfs-3g /dev/sdg1 /media/Downloads
ntfs-3g-mount: failed to access mountpoint /media/Downloads: Input/output error

If I manage to mount it via

mount -t ntfs-3g /dev/sdg1 /media/Downloads

Once I cd into it:

cd media/Downloads 
root@athena:/media/Downloads# ls -l
ls: reading directory .: Input/output error
total 0
root@athena:/media/Downloads#

mount however, says:

/dev/sdf1 on /media/Downloads type fuseblk (rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096)

What did I brake?

EDIT

ntfsinfo -m /dev/sdg1

Volume is scheduled for check.
Please boot into Windows TWICE, or use the 'force' option.
NOTE: If you had not scheduled check and last time accessed this volume
using ntfsmount and shutdown system properly, then init scripts in your
distribution are broken. Please report to your distribution developers
(NOT to us!) that init scripts kill ntfsmount or mount.ntfs-fuse during
shutdown instead of proper umount.
Failed to open '/dev/sdg1'.

EDIT#2

ntfsinfo -fm /dev/sdg1 
WARNING: Dirty volume mount was forced by the 'force' mount option.
Volume Information 
        Name of device: /dev/sdg1
        Device state: 11
        Volume Name: 
        Volume State: 91
        Volume Flags: 0x0001 DIRTY
        Volume Version: 3.1
        Sector Size: 4096
        Cluster Size: 4096
        Index Block Size: 4096
        Volume Size in Clusters: 253473506
MFT Information 
        MFT Record Size: 4096
        MFT Zone Multiplier: 0
        MFT Data Position: 24
        MFT Zone Start: 0
        MFT Zone End: 31684192
        MFT Zone Position: 4
        Current Position in First Data Zone: 31684192
        Current Position in Second Data Zone: 0
        Allocated clusters 145403 (0.1%)
        LCN of Data Attribute for FILE_MFT: 4
        FILE_MFTMirr Size: 4
        LCN of Data Attribute for File_MFTMirr: 126736753
        Size of Attribute Definition Table: 2560
        Number of Attached Extent Inodes: 0
FILE_Bitmap Information 
        FILE_Bitmap MFT Record Number: 6
        State of FILE_Bitmap Inode: 80
        Length of Attribute List: 0
        Number of Attached Extent Inodes: 0
FILE_Bitmap Data Attribute Information
        Decompressed Runlist: not done yet
        Base Inode: 6
        Attribute Types: not done yet
        Attribute Name Length: 0
        Attribute State: 3
        Attribute Allocated Size: 31686656
        Attribute Data Size: 31684192
        Attribute Initialized Size: 31684192
        Attribute Compressed Size: 0
        Compression Block Size: 0
        Compression Block Size Bits: 0
        Compression Block Clusters: 0
        Free Clusters: 199331046 (78.6%)

I will try mounting it under windows in a few hours (I'm running a check on another disk I don't want to interrupt).

EDIT#3

I went back into windows, and scanned the disks. Windows indeed found problems with one of them, but both were fixed, mountable and browsable.

Yet, under Debian, I still cannot do anything. I opened Gparted, and interestingly enough, it complains:

Unable to read the contents of this file system!
Because of this some operations may be unavailable.
The cause might be a missing software package.
The following list of software packages is required for ntfs file system support:  ntfsprogs / ntfs-3g.

However,

apt-cache policy ntfs-3g
ntfs-3g:
  Installed: 1:2014.2.15AR.2-1
  Candidate: 1:2014.2.15AR.2-1
  Version table:
 *** 1:2014.2.15AR.2-1 0

!!! So, have I run into some kind of ntfs-3g bug, or is my system now broken???

  • Hrm... either reboot and have windows chkdsk it, or you might try adding -f to ntfsinfo – psusi Oct 30 '14 at 18:02
  • It seems to me like its mounted OK, but reading from it is not working. Same with an internal NTFS hardisk. – Alex Oct 30 '14 at 18:16
11

It is ntfs-3g bug. Downgrade ntfs-3g and it will work. I had the same problem with 1:2014 version, and no problem with 1:2012 version (which in "stable" repository)

  • 1
    It's bettter if you mentioned to bug, refer to link of it. – PersianGulf Oct 31 '14 at 8:21
  • That's interesting, I will try this and get back to you. – Alex Oct 31 '14 at 18:50
  • 1
    Yes you are right, I downgraded to 1:2012 and it works! – Alex Oct 31 '14 at 19:24
  • 1
    This answer saved me a lot of heartache. Thank you @Alex and @skilowatt! – Steven Edwards Mar 26 '15 at 19:34
0

since version 1:2012 is no longer in stable (Jessie), upgrade to unstable (Sid), which is currently version 1:2016.2.22AR.1-3, as mentioned in the bug report linked to by skilowatt.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.