On my new computer I have 2 screens connected on the igpu of a i7 processor, 1 using hdmi. the other using dvi. Both screens are the same but the one connected using hdmi has a wrong resolution inside X, and it can't be selected inside the settings. How can this be solved?

  • Which one shows "wrong resolution"? Hardware details, in particular maximal resolutions? – vonbrand Nov 14 '15 at 10:07
up vote 3 down vote accepted

first run

$ xrandr

this will give output like this:

Screen 0: minimum 320 x 200, current 5120 x 1080, maximum 8192 x 8192
HDMI1 connected 2560x1080+2560+0 (normal left inverted right x axis y axis) 677mm x 290mm 
   1920x1080     60.00*  
   1680x1050     59.88  
   1600x900      59.98  
...

HDMI2 connected 2560x1080+0+0 (normal left inverted right x axis y axis) 677mm x 290mm
   2560x1080     60.00*+
   2560x1080_60.00  59.98  
   1920x1080     60.00    50.00    59.94    30.00    29.97  
   1920x1080i    60.00    50.00    59.94  
... 

to add 2560x1080 to HDMI1 first run the next command

$ cvt 2560 1080

sample output:

2560x1080 59.98 Hz (CVT) hsync: 67.17 kHz; pclk: 230.00 MHz
Modeline "2560x1080_60.00"  230.00  2560 2720 2992 3424  1080 1083 1093 1120 -hsync +vsync

now you need to use this output to test the resolution and than add the settings for use in the next sessions.

testing:

$ xrandr --newmode "2560x1080_60.00"  230.00  2560 2720 2992 3424  1080 1083 1093 1120 -hsync +vsync
$ xrandr --addmode HDMI1 2560x1080_60.00
$ xrandr --output HDMI1 --mode 2560x1080_60.00

if it works you can add it to the xorg configuration

$ sudo vim /etc/X11/xorg.conf.d/40-monitor.conf

or

$ sudo vim /usr/share/X11/xorg.conf.d/40-monitor.conf

Section "Monitor"
    Identifier "HDMI1"
    Modeline "2560x1080_60.00"  230.00  2560 2720 2992 3424  1080 1083 1093 1120 -hsync +vsync
    Option "PreferredMode" "2560x1080"
EndSection
  • Is the resolution ment to change when I run --addmode? Or is it going to appear in the display settings? (I am using debian) – Marcus Johansson Nov 23 '14 at 13:00
  • It is added to the display settings, you stillbhave to set the resolution. – switch87 Nov 23 '14 at 20:23
  • Excellent: by that I mean it worked (which is something great). One minor point for me. I had to add video=HDMI-A-1:e – rrogers Aug 31 '17 at 14:49
  • Excellent: by that I mean, it worked (which is something great). One minor point for me. I had to add video=HDMI-A-1:e to the end of kernel mode settings. I have forgotten where I got that name from; xrandr says HDMI-0 for a name. I still haven't quite got my booting stable but once it boots the above procedure takes hold. My bios doesn't play nice with some versions of X11. – rrogers Aug 31 '17 at 15:07

Only switching to Nouveau drivers helped.

  1. Install nouveau package, relevant to your distribution.
  2. Disable blacklisting from "/usr/lib/modprobe.d/nvidia.conf".
  3. Add noveau drivers to xorg configuration.

Reference: Missing 2560x1080 from Linux Nvidia Control Panel

  • This is the exact same lg display I have, my method works on Nvidia and Intel (only ones I tried on). The problem has nothing to do with the gpu driver, only with the information given to the computer by the display itself – switch87 Jun 1 at 9:39
  • Actually this is the only thing that worked for me. And monitor not having anything to do with display driver is just plain wrong mate. – ram4nd Jun 2 at 10:26
  • The resolutions given back by the display are co trolled by the display firmware, not by the gpu driver (you do not have a display driver). LG has quite a lot displays with this kind of problems it seems. – switch87 Jun 3 at 21:57
  • And the display drivers differ in native drivers and nouveau drivers. – ram4nd Jun 4 at 5:30

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.