1

On my lubuntu 13.10, I created a degraded RAID array, copied all the contents of the "main" disk and tried to boot from the array. I mostly followed these instructions.

At boot the system does not recognize the root partition (ALERT! /dev/disk/by-uuid/THE-ROOT-ARRAY-ID does not exist). I executed blkid from initramfs shell and raid arrays were not listed.

UPDATE:

Also cat /proc/mdstat and ls /dev/md* gives me no result. I also tried to add the raid1 module manually to /etc/initramfs-tools/modules, but nothing. Raid arrays are not assembled even during normal boot: I stopped it editing the root UUID in the main menuentry from grub.

Note that if the OS starts normally, arrays are assembled. Furthermore I can assemble the arrays in the initramfs shell mounting manually the root partition and executing

/mnt/sbin/mdadm --assemble --scan

OLD INFORMATIONS (probably useless):

So I checked if correct raid modules are loaded using

sudo update-initramfs -u -k all -v > ~/initout.txt
cat ~/initout.txt | grep raid

This is the result:

Adding module /lib/modules/3.11.0-13-generic/kernel/lib/raid6/raid6_pq.ko
Adding module /lib/modules/3.11.0-13-generic/kernel/drivers/scsi/raid_class.ko
Adding module /lib/modules/3.11.0-13-generic/kernel/drivers/scsi/aacraid/aacraid.ko
Adding module /lib/modules/3.11.0-13-generic/kernel/drivers/scsi/megaraid.ko
Adding module /lib/modules/3.11.0-13-generic/kernel/drivers/scsi/megaraid/megaraid_mm.ko
Adding module /lib/modules/3.11.0-13-generic/kernel/drivers/scsi/megaraid/megaraid_sas.ko
Adding module /lib/modules/3.11.0-13-generic/kernel/drivers/scsi/megaraid/megaraid_mbox.ko
Adding module /lib/modules/3.11.0-13-generic/kernel/drivers/scsi/pmcraid.ko
[...]

It seems that the correct raid module, /lib/modules/3.11.0-13-generic/kernel/drivers/md/raid1.ko, is not added. This is the content of my /etc/mdadm.conf file:

DEVICE /dev/sda* /dev/sdb*

ARRAY /dev/md/root metadata=1.2 name=root-array UUID=0e3ae751:5bca2767:a0de084c:c92033b1
ARRAY /dev/md/win  metadata=1.2 name=win-array  UUID=3c03111e:2658df20:2a8aba2d:e6ade522
ARRAY /dev/md/boot metadata=1.2 name=boot-array UUID=ab40adc4:20238d93:29ee1ab5:22608d05
ARRAY /dev/md/home metadata=1.2 name=home-array UUID=13768370:b8b8d4f4:aef53340:64626427
ARRAY /dev/md/swap metadata=1.2 name=swap-array UUID=fea8ebfd:b2c87eb2:4d8642d5:5adbb6e0

I also tried to move it to /etd/mdadm/mdadm.conf without success.

  • You know 13.10 reached end of life 6 months ago and is no longer supported right? You need to upgrade. Also cat /proc/mdstat. – psusi Oct 30 '14 at 14:09
  • @psusi: I updated the question. – Marco Sulla Oct 30 '14 at 17:03
0

I've found the problem. I installed and compiled mdadm from source instead of installing it from repo, because of I was not sure the repo version support grub very well.

It seems that automatic inclusion of mdadm in initramfs is not supported by mdadm, but it's leaved to distro maintainers.

I manually removed it and reinstalled the repo version, all works now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.