7

I've followed the instructions on the Elixir site for Ubuntu by downloading and installing their erlang-solutions_1.0_all.deb but no install target is found when trying to install.

$ sudo apt-get install elixir                           
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package elixir

No matching target in apt-cache

$ sudo apt-cache search elixir
elyxer - standalone LyX to HTML converter
libelixirfm-perl - perl implementation for Functional Arabic Morphology
python-elixir - Declarative Mapper for SQLAlchemy

Erlang solutions repo in sources

$ ll /etc/apt/sources.list.d 
total 12K
-rw-r--r-- 1 root root 183 Oct 29 23:38 erlang-solutions.list
-rw-r--r-- 1 root root  58 Nov 26  2013 getdeb.list
-rw-r--r-- 1 root root 458 Apr 20  2014 official-package-repositories.list

I'm running Linux Mint 16 (Petra) based on Ubuntu 13.10 (Saucy Salamander)

$ cat /etc/apt/sources.list.d/erlang-solutions.list
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://binaries.erlang-solutions.com/debian saucy contrib

$ sudo apt-get update | grep erlang
Ign http://binaries.erlang-solutions.com saucy InRelease
Hit http://binaries.erlang-solutions.com saucy Release.gpg
Hit http://binaries.erlang-solutions.com saucy Release
Hit http://binaries.erlang-solutions.com saucy/contrib amd64 Packages
Hit http://binaries.erlang-solutions.com saucy/contrib i386 Packages
Ign http://binaries.erlang-solutions.com saucy/contrib Translation-en_GB
Ign http://binaries.erlang-solutions.com saucy/contrib Translation-en

Not sure why this repo doesn't provide me with an install target for elixir.

3

As you could have guessed, the package elixir isn't available in anything that isn't Ubuntu 12.04, Ubuntu 14.04 (and probably later) and Debian 7. You can check the packages list for Saucy, and you will notice the package isn't there. Trusty repository does have it:

Package: elixir
Version: 0.13.3-1
Architecture: all
Maintainer: Erlang Solutions <packages@erlang-solutions.com>
Installed-Size: 3291
Depends: erlang-base (>= 1:17.0) | erlang-base-hipe (>= 1:17.0) | esl-erlang (>= 1:17.0)
Section: contrib
Priority: optional
Homepage: http://elixir-lang.org
Filename: pool/elixir_0.13.3-1~ubuntu~trusty_amd64.deb

What you should do is using one of the supported systems and you will be fine.

  • I'll try changing my sources to use the 12.04 package and see if it works with Mint 16. Thanks for the help – Greg K Oct 30 '14 at 10:36
15

I tried too from Elixir's documentation; at first I failed, then eventually installed elixir successfully on my MintDebian1 (Debian wheezy).

I don't really know what's going on. I tend to think they have a typo on their documentation and wrote apt-get install elixir instead of erlang, because all other blog posts I found that use the same .deb do install erlang and then install elixir manually.

I went to /etc/apt/sources.list.d/erlang-solutions.list, changed squeeze to wheezy, ran apt-get update and finally I found elixir and all is well.

PS: it is possible to not install Elixir but still run it, and the iex repl too, from a Docker image. See https://registry.hub.docker.com/u/nifty/elixir/

  • 1
    Changing squeeze to wheezy fixed it. Thanks. – Francisco Jan 29 '17 at 1:32
  • Using LMDE 2, this worked! – Shautieh Aug 23 '17 at 12:49
1

I just had the same problem and my system is Ubuntu 14.04, i.e. one of the systems that the Elixir installation link in the question suposedly supports.

The esl-erlang that I installed (as per the Elixir link above) failed to work with a precompiled Elixir binary that I downloaded from github. I therefore purged that erlang install (sudo apt-get purge esl-erlang) and went to the Erlang installation web page, which also has a tab for Elixir.

I first followed the alternative Erlang OTP instructions; I added the appropriate line to my /etc/apt/sources.list and then manually adding the public key. Finally, after running sudo apt-get update, I successfully installed both esl-erlang and elixir.

I am now running iex successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.