2

Since a couple of days, I'm unable to retrieve repositories data with Yum, in my CentOS 6.5 server. I did yum clean all a dozen of times, it emptied all but didn't solved the problem.

I tried to retrieve things by restricting to the single base repo :

[base]
name=CentOS-$releasever - Base
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6

yum --verbose update results in :

Loading "fastestmirror" plugin
Loading "priorities" plugin
Config time: 0.010
Yum Version: 3.2.29
Setting up Package Sacks
Determining fastest mirrors
Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=6&arch=x86_64&repo=os error was
14: PYCURL ERROR 22 - "The requested URL returned error: 403 Forbidden"
Error: Cannot find a valid baseurl for repo: base

And when I configure a baseurl instead of a mirrorlist, I get this :

Loading "fastestmirror" plugin
Loading "priorities" plugin
Config time: 0.010
Yum Version: 3.2.29
Setting up Package Sacks
Determining fastest mirrors
http://mirror.centos.org/centos/6/os/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: base. Please verify its path and try again

The server pings mirror.centos.org and I can reach without any problem the mirrorlist and the repomd.xml in a web browser. Disabling the plugins changed nothing. The mirrorlist gives a 403 error and a baseurl 404...

rpm -q --verify -f /etc/yum.repos.d/* results in :

S.5....T.  c /etc/issue
.......T.  c /etc/yum.repos.d/CentOS-Base.repo
.......T.  c /etc/yum.repos.d/CentOS-Debuginfo.repo
.......T.  c /etc/yum.repos.d/CentOS-Media.repo
.......T.  c /etc/yum.repos.d/CentOS-Vault.repo
S.5....T.  c /etc/issue
.......T.  c /etc/yum.repos.d/CentOS-Base.repo
.......T.  c /etc/yum.repos.d/CentOS-Debuginfo.repo
.......T.  c /etc/yum.repos.d/CentOS-Media.repo
.......T.  c /etc/yum.repos.d/CentOS-Vault.repo
S.5....T.  c /etc/issue
.......T.  c /etc/yum.repos.d/CentOS-Base.repo
.......T.  c /etc/yum.repos.d/CentOS-Debuginfo.repo
.......T.  c /etc/yum.repos.d/CentOS-Media.repo
.......T.  c /etc/yum.repos.d/CentOS-Vault.repo
S.5....T.  c /etc/issue
.......T.  c /etc/yum.repos.d/CentOS-Base.repo
.......T.  c /etc/yum.repos.d/CentOS-Debuginfo.repo
.......T.  c /etc/yum.repos.d/CentOS-Media.repo
.......T.  c /etc/yum.repos.d/CentOS-Vault.repo
.......T.  c /etc/yum.repos.d/epel-testing.repo
.......T.  c /etc/yum.repos.d/epel.repo
.......T.  c /etc/yum.repos.d/epel-testing.repo
.......T.  c /etc/yum.repos.d/epel.repo
le fichier /etc/yum.repos.d/isv:ownCloud:community.repo n'appartient à aucun paquetage
.......T.  c /etc/yum.repos.d/jpackage.repo
le fichier /etc/yum.repos.d/jpackage.repo.rpmsave n'appartient à aucun paquetage

« n'appartient à aucun paquetage » means « doesn't belong to any package », in french...

Those problems occur with whatever repo I enable/disable.

  • Try this: yum --verbose update to see if you can get additional insight. – slm Oct 29 '14 at 15:40
  • Try mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os&infra=$infra – fpmurphy Jan 14 '17 at 1:14
0

Need to look at the contents of /etc/yum.repos.d/ and also the output of the following command to be able to debug:

$ rpm -q --verify -f /etc/yum.repos.d/*

I had once got into a similar problem and the quick solution was to disable the offending repo by changing the enabled variable to 0 in the correct yum config file. But your error is not related to any particular repo.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.