9

When I start Thunderbird (31.2.0 under Ubuntu 14.04), my Outlook 365 account john.doe@example.com accessed over IMAP is completely unreachable (I can't even see the list of folders, even though I have local archives). I see the following message in a D-Bus notification (several times):

The current operation on 'Inbox' did not succeed. The mail server for account john.doe@example.com responded: User is authenticated but not connected.

This account has been working for a while. I changed my password during my previous Thunderbird session; after entering the new password, Thunderbird still worked.

What does this seemingly nonsensical message “User is authenticated but not connected” mean? How do I get my email?

  • I had this exact problem on Mac OS X 10.10.1 Yosemite, also accessing an Office 365 account over IMAP using Mozilla Thunderbird 31.2.0. The proposed fix worked perfectly. I also had to resync the account's folders as they had apparently been deleted locally. Also in my case, the issue appeared after I changed my password. I've done this several times before without problem. A possible contributing reason might be that I this time changed the password directly in AD, rather than through any user-side facilities. – anlag Dec 1 '14 at 13:01
9

The message “User is authenticated but not connected” is due to a bug in the Exchange server's IMAP implementation. If the client presents a valid user name but an invalid password, the server accepts the login, but subsequent commands fail with the aforementioned error message. Source: SaneBox blog.

So I need to change the password stored by Thunderbird. There's no actual way to change the password except at a password prompt (which Thunderbird doesn't show since the server never tells it that the password is invalid). I first need to make Thunderbird forget my saved password: use the “Preferences” → “Preferences” menu, go to the “Security” → “Passwords” tab, click the “Saved Passwords...” button and remove the entry(s) that have the old password.

I don't know why I still had the old password there. It's possible that Thunderbird had worked after the password change only because existing connections had remained open.

I then restarted Thunderbird (I couldn't find an easier way to make it re-attempt to connect to the Exchange server).

Thunderbird deleted all my local archives for this account. I think it decided that the folders had been deleted on the server when it received an unknown error from the server, instead of treating the error as an error. This is a bug in Thunderbird, I haven't tracked it down. When I subsequently changed my password again, I closed Thunderbird first, and it didn't delete any archives.

3

I have this problem from time to time. Most recently I tried changing the "maximum number of connections to cache" to 1 and it solved the problem (possibly just a coincidence but it was correlated enough to post here)..

You can do this under Edit->Account Settings->Server Settings->Advanced...

Not the answer you're looking for? Browse other questions tagged or ask your own question.