0

I installed apache on my RHEL machine yesterday and found I could access it from a browser using http://. Of course, sshing using the hostname was also working.

So, I made an index.html file inside it (/var/www) and was able to view it from other computers on the network.

However, I made some changes to the index.html file today and the changes just wouldn't reflect on the web browser of other computers when I refreshed it. Finally, the browser just started saying it couldn't find the server. I tried using the ip-address instead: http:///index.html and it worked as expected. Now, I can't even ssh to my linux machine using my hostname. Does any one know what might have happened (note that all was well yesterday - the only playing around I did was update the index.html file and refresh the browser from another computer)?

1

The first step in answering this is to determine why it worked in the first place.

Do you know if names on your network are resolved using DNS, or windows-based NetBIOS queries?

One way machine names get registered is by manually registering them with the DNS server for your local network. Another way is by your server sending its name to the DHCP server as it gets an automatic IP address. And the third common way is by using Samba in a Windows domain scenario, where the NetBIOS name becomes available to other machines.

The answer gets kinda long at this point, if I branch off into all the scenarios. So let us know a little more about your network, and I can extend the answer if needed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.