2

I have an Acer Aspire 4820TG. It has an integrated and a dedicated graphics card, the latter is an ATI Mobility Radeon HD 5650.

The installation of Elementary OS (Luna) went fine but I needed hardware acceleration, so I tried to install ATI drivers from the system settings. Installation went fine but it got stuck on the reboot, somewhere near "checking battery status" or "preload: ".

After some trial and error, involving mess things up with xorg.conf, I managed to get it back where it was before installing the drivers. So I decided to try again but this time no drivers showed up on the settings.

I tried to download the drivers from AMD site, installed them and got the same problem as before, the difference is that now I can't revert it back. I tried to remove all the fglrx packages I had, use the very first xorg.conf I had, but no luck.

How can I make it working again without reinstalling the os? And if it's my only option, what is the best way to install those drivers?

EDIT: updates.
I reinstalled mesa and xserver-xorg-video stuff, now it works but xorg.conf is still messed up, /etc/X11/xorg.confdoesn't exist (it wasn't recreated automagically?) and the touchpad doesn't work at all too. However glxinfo says it's using direct rendering, but I bet it's still the integrated graphics.

  • god help you, the ATI drivers doesn't work well on Unix I don't know why but it is, I had almost same problem and I had to install ubuntu instead. – Vivian Maya Oct 28 '14 at 22:27
  • @vivian actually a year ago I used ubuntu with ati drivers on the same machine with no problems. – n1xx1 Oct 29 '14 at 5:32
  • Is your Integrated Graphics Card Intel Based? Is VGA Switcharoo enabled in your Kernel, and have you installed the Hybrid Graphics Driver for your platform? – eyoung100 Oct 29 '14 at 13:53
  • So I ended up installing Ubuntu 14.10, but still can't install proprietary drivers. However I managed to get Hardware Acceleration going using vesa. Still having some troubles with Steam but I've submitted an issue on the github repo. – n1xx1 Oct 30 '14 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.